summaryrefslogtreecommitdiffstats
path: root/gentoo/trinity-base/kghostview/files/tdegraphics-fix-kghostview-parallel-compilation.patch
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-11-19 17:45:28 +0100
committerSlávek Banko <slavek.banko@axis.cz>2019-11-19 17:45:28 +0100
commite6636bd5d6280d92996bd70b744e8a29e54c7e18 (patch)
tree014989bddcbc22c7a8d4dafa7b78f3e55b184718 /gentoo/trinity-base/kghostview/files/tdegraphics-fix-kghostview-parallel-compilation.patch
parent4b7471734323c7cb5bdc129857c94041418c81b5 (diff)
downloadtde-packaging-e6636bd5d6280d92996bd70b744e8a29e54c7e18.tar.gz
tde-packaging-e6636bd5d6280d92996bd70b744e8a29e54c7e18.zip
Gentoo: Initial import of an ebuilds tree
from Fat-Zer's (Alexander Golubev) repository. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'gentoo/trinity-base/kghostview/files/tdegraphics-fix-kghostview-parallel-compilation.patch')
-rw-r--r--gentoo/trinity-base/kghostview/files/tdegraphics-fix-kghostview-parallel-compilation.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/gentoo/trinity-base/kghostview/files/tdegraphics-fix-kghostview-parallel-compilation.patch b/gentoo/trinity-base/kghostview/files/tdegraphics-fix-kghostview-parallel-compilation.patch
new file mode 100644
index 000000000..3aa8138a6
--- /dev/null
+++ b/gentoo/trinity-base/kghostview/files/tdegraphics-fix-kghostview-parallel-compilation.patch
@@ -0,0 +1,24 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index c87ee85..09c3cfa 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -95,7 +95,8 @@ set( CMAKE_MODULE_LINKER_FLAGS "-Wl,--no-undefined" )
+
+ ##### tdegraphics directories ###################
+
+-if( BUILD_KFILE_PLUGINS OR BUILD_GHOSTKVIEW )
++# kghostview/ps requires dscparse-static library
++if( BUILD_KFILE_PLUGINS AND NOT BUILD_KGHOSTVIEW )
+ add_subdirectory( kghostview/dscparse )
+ endif( )
+
+--- a/kghostview/CMakeLists.txt
++++ b/kghostview/CMakeLists.txt
+@@ -10,6 +10,7 @@
+ #################################################
+
+ add_subdirectory( data )
++add_subdirectory( dscparse )
+
+ include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}