summaryrefslogtreecommitdiffstats
path: root/redhat/dependencies/arts/trinity-arts-3.5.13.spec
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-09-05 13:53:08 -0500
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-09-05 13:53:08 -0500
commited4fba5b52a126babf633ece832bed7cc50347e4 (patch)
treedf4dda5b511fe6a3930c567d2391a9f574570618 /redhat/dependencies/arts/trinity-arts-3.5.13.spec
parent9135c977131b957134d4b691542998b2dc397378 (diff)
parent3c86eeb8b77e5ea83ce7938d75c17b7bde9b31d5 (diff)
downloadtde-packaging-ed4fba5b52a126babf633ece832bed7cc50347e4.tar.gz
tde-packaging-ed4fba5b52a126babf633ece832bed7cc50347e4.zip
Merge branch 'master' of http://scm.trinitydesktop.org/scm/git/tde-packaging
Diffstat (limited to 'redhat/dependencies/arts/trinity-arts-3.5.13.spec')
-rwxr-xr-xredhat/dependencies/arts/trinity-arts-3.5.13.spec117
1 files changed, 117 insertions, 0 deletions
diff --git a/redhat/dependencies/arts/trinity-arts-3.5.13.spec b/redhat/dependencies/arts/trinity-arts-3.5.13.spec
new file mode 100755
index 000000000..23d08c4d9
--- /dev/null
+++ b/redhat/dependencies/arts/trinity-arts-3.5.13.spec
@@ -0,0 +1,117 @@
+# Default version for this component
+%if "%{?version}" == ""
+%define version 1.5.10
+%endif
+
+# If TDE is built in a specific prefix (e.g. /opt/trinity), the release will be suffixed with ".opt".
+%if "%{?_prefix}" != "/usr"
+%define _variant .opt
+%define _libdir %{_prefix}/lib
+%endif
+
+
+Name: trinity-arts
+Version: %{version}
+Release: 0%{?dist}%{?_variant}
+License: GPL
+Summary: aRts (analog realtime synthesizer) - the KDE sound system
+Vendor: Trinity Project
+Packager: Francois Andriot <francois.andriot@free.fr>
+
+Source0: arts-%{version}.tar.gz
+Prefix: %{_prefix}
+
+BuildRequires: cmake >= 2.8
+BuildRequires: tde-cmake-macros
+BuildRequires: qt3-devel >= 3.3.8d
+BuildRequires: tqtinterface-devel
+BuildRequires: audiofile-devel
+BuildRequires: alsa-lib-devel
+BuildRequires: glib2-devel
+BuildRequires: libtool-ltdl-devel
+
+Requires: qt3 >= 3.3.8d
+Requires: tqtinterface
+Requires: audiofile
+
+%if "%{?_prefix}" == "/usr"
+Obsoletes: arts
+%endif
+
+%description
+arts (analog real-time synthesizer) is the sound system of KDE 3.
+
+The principle of arts is to create/process sound using small modules which do
+certain tasks. These may be create a waveform (oscillators), play samples,
+filter data, add signals, perform effects like delay/flanger/chorus, or
+output the data to the soundcard.
+
+By connecting all those small modules together, you can perform complex
+tasks like simulating a mixer, generating an instrument or things like
+playing a wave file with some effects.
+
+
+%package devel
+Requires: %{name}
+Summary: %{name} - Development files
+%if "%{?_prefix}" == "/usr"
+Obsoletes: arts-devel
+%endif
+
+%description devel
+Development files for %{name}
+
+%prep
+%setup -q -n dependencies/arts
+
+%build
+unset QTDIR || : ; . /etc/profile.d/qt.sh
+
+%__mkdir build
+cd build
+%cmake \
+ -DPKGCONFIG_INSTALL_DIR=%{_libdir}/pkgconfig \
+ -DWITH_MAD=OFF \
+ ..
+
+%__make %{?_smp_mflags}
+
+%install
+%make_install -C build
+
+%clean
+%__rm -rf %{?buildroot}
+
+%files
+%defattr(-,root,root,-)
+%doc COPYING.LIB
+%dir %{_libdir}/mcop
+%dir %{_libdir}/mcop/Arts
+%{_libdir}/mcop/Arts/*
+%{_libdir}/mcop/*.mcopclass
+%{_libdir}/mcop/*.mcoptype
+%{_libdir}/lib*.so.*
+%{_libdir}/lib*.la
+%{_bindir}/artscat
+%{_bindir}/artsd
+%{_bindir}/artsdsp
+%{_bindir}/artsplay
+%{_bindir}/artsrec
+%{_bindir}/artsshell
+%{_bindir}/artswrapper
+
+%files devel
+%defattr(-,root,root,-)
+%{_bindir}/mcopidl
+%dir %{_includedir}
+%{_includedir}/*/
+%{_bindir}/artsc-config
+%{_libdir}/lib*.so
+%{_libdir}/pkgconfig/*.pc
+%exclude %{_libdir}/*.a
+
+
+%changelog
+* Fri Sep 02 2011 Francois Andriot <francois.andriot@free.fr> - 1.5.10-0
+- Import to GIT
+- Built with future TDE version (3.5.13 + cmake + QT3.3.8d)