summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/knemo/debian/rules
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-05-04 19:02:48 +0200
committerSlávek Banko <slavek.banko@axis.cz>2019-05-04 19:03:30 +0200
commit17012e1505323967184a98a28da8bbe8b1a8762a (patch)
treefb056a7b6127d2681e0bde35e57d2c85293a1841 /ubuntu/_base/applications/knemo/debian/rules
parent31fc951bd08b33682f26a4b820f51d679787b219 (diff)
downloadtde-packaging-17012e1505323967184a98a28da8bbe8b1a8762a.tar.gz
tde-packaging-17012e1505323967184a98a28da8bbe8b1a8762a.zip
DEB knemo: Switch to cmake.
Add basic package documentation. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 38c37e29fdc8d281ae7eed87cf313833ac2c003e)
Diffstat (limited to 'ubuntu/_base/applications/knemo/debian/rules')
-rwxr-xr-xubuntu/_base/applications/knemo/debian/rules41
1 files changed, 11 insertions, 30 deletions
diff --git a/ubuntu/_base/applications/knemo/debian/rules b/ubuntu/_base/applications/knemo/debian/rules
index f352ffb69..0f312cb4c 100755
--- a/ubuntu/_base/applications/knemo/debian/rules
+++ b/ubuntu/_base/applications/knemo/debian/rules
@@ -1,35 +1,16 @@
#!/usr/bin/make -f
include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
include debian/cdbs/debian-tde.mk
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
-DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
-DEB_CONFIGURE_PREFIX := /opt/trinity
-DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
-
-cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
-
-DEB_INSTALL_DOCS_knemo = -XNEWS
-
-DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib --with-extra-includes=/opt/trinity/include/tde
-
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
-
-post-patches:: debian/stamp-bootstrap
-
-debian/stamp-bootstrap:
-ifneq "$(wildcard /usr/share/libtool/ltmain.sh)" ""
- cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
- cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
- cp -f /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
-endif
- cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-
- make -f admin/Makefile.common cvs
- touch debian/stamp-bootstrap
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"