summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/tdedocker/debian/rules
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2020-03-27 00:31:48 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2020-03-27 00:38:39 +0900
commit2d24070a83823c313bbe6632b0b9f41b27b85564 (patch)
tree1d5d99bdacb65999a97c5411ceaacf3e82f70b61 /ubuntu/_base/applications/tdedocker/debian/rules
parentc5ea458e87ffef31111418dd1efc0d39688ac521 (diff)
downloadtde-packaging-2d24070a83823c313bbe6632b0b9f41b27b85564.tar.gz
tde-packaging-2d24070a83823c313bbe6632b0b9f41b27b85564.zip
DEB tdedocker:
1) removed man file (now part of main application) 2) added Debian menu file 3) added support for cmake WITH_ALL_OPTIONS Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'ubuntu/_base/applications/tdedocker/debian/rules')
-rwxr-xr-xubuntu/_base/applications/tdedocker/debian/rules9
1 files changed, 5 insertions, 4 deletions
diff --git a/ubuntu/_base/applications/tdedocker/debian/rules b/ubuntu/_base/applications/tdedocker/debian/rules
index eb2a2e4b5..18aa16b96 100755
--- a/ubuntu/_base/applications/tdedocker/debian/rules
+++ b/ubuntu/_base/applications/tdedocker/debian/rules
@@ -4,6 +4,9 @@ include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/cmake.mk
include debian/cdbs/debian-tde.mk
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
DEB_CMAKE_EXTRA_FLAGS := \
-DCMAKE_INSTALL_PREFIX="/opt/trinity" \
-DCONFIG_INSTALL_DIR="/etc/trinity" \
@@ -12,7 +15,5 @@ DEB_CMAKE_EXTRA_FLAGS := \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_VERBOSE_MAKEFILE="ON" \
-DCMAKE_SKIP_RPATH="OFF" \
- -DBUILD_ALL="ON"
-
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"