summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/dependencies/arts/debian/rules
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2020-11-14 11:45:52 +0800
committerMichele Calgaro <michele.calgaro@yahoo.it>2020-11-14 11:45:52 +0800
commiteb16e7c7281e182297581fa8d565561869c81bca (patch)
tree4edf3c2dcd2a70e76c9581f04fbeb7d2a729f8b6 /ubuntu/_base/dependencies/arts/debian/rules
parent2064c92d78e53c5753ccc22a2b83abfe120fa8cb (diff)
downloadtde-packaging-eb16e7c7281e182297581fa8d565561869c81bca.tar.gz
tde-packaging-eb16e7c7281e182297581fa8d565561869c81bca.zip
DEB: added cmake directive to create compilation database 'compile_commands.json' at build time.
This can be used to provide linting, autocompletion, hovering info, go-to-definition and in general other LSP functionality in development environments. Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'ubuntu/_base/dependencies/arts/debian/rules')
-rwxr-xr-xubuntu/_base/dependencies/arts/debian/rules17
1 files changed, 15 insertions, 2 deletions
diff --git a/ubuntu/_base/dependencies/arts/debian/rules b/ubuntu/_base/dependencies/arts/debian/rules
index c3167d04f..708852525 100755
--- a/ubuntu/_base/dependencies/arts/debian/rules
+++ b/ubuntu/_base/dependencies/arts/debian/rules
@@ -12,8 +12,21 @@ include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/cmake.mk
include debian/cdbs/debian-tde.mk
-DEB_CMAKE_EXTRA_FLAGS := -DPKGCONFIG_INSTALL_DIR="/usr/lib/pkgconfig" -DLIB_SUFFIX="" -DCMAKE_INSTALL_PREFIX="/opt/trinity" -DCONFIG_INSTALL_DIR="/etc/trinity" -DSYSCONF_INSTALL_DIR="/etc/trinity" -DCMAKE_LIBRARY_PATH="/opt/trinity/lib" -DCMAKE_INCLUDE_PATH="/opt/trinity/include/tde" -DAUTODETECT_QT_DIRS="ON" -DCMAKE_VERBOSE_MAKEFILE="ON" -DBUILD_ALL="ON" -DCMAKE_SKIP_RPATH="OFF" -DWITH_GCC_VISIBILITY="ON" \
--DCMAKE_BUILD_TYPE=RelWithDebInfo
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
+ -DPKGCONFIG_INSTALL_DIR="/usr/lib/pkgconfig" \
+ -DLIB_SUFFIX="" \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DCMAKE_LIBRARY_PATH="/opt/trinity/lib" \
+ -DCMAKE_INCLUDE_PATH="/opt/trinity/include/tde" \
+ -DAUTODETECT_QT_DIRS="ON" \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DBUILD_ALL="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DWITH_GCC_VISIBILITY="ON" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo
DEB_DH_STRIP_ARGS := --dbg-package=arts-trinity-dbg