summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/dependencies/libart-lgpl/debian/rules
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-04-28 16:06:24 +0200
committerSlávek Banko <slavek.banko@axis.cz>2019-04-28 16:06:47 +0200
commitc086aee1d6ad6bd12280179a33b04e1f8e50b497 (patch)
tree0ea27a0cfa6b8448d326538bf737051be1b84c7e /ubuntu/_base/dependencies/libart-lgpl/debian/rules
parent4df0f7bda98ac7c49d2700f7de0570123de9fd73 (diff)
downloadtde-packaging-c086aee1d6ad6bd12280179a33b04e1f8e50b497.tar.gz
tde-packaging-c086aee1d6ad6bd12280179a33b04e1f8e50b497.zip
DEB libart-lgpl: Switch to cmake.
The man page has been moved to the main tree. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit cb03ac17a2533aa0b9c2e5f966bee5cf5e02df07)
Diffstat (limited to 'ubuntu/_base/dependencies/libart-lgpl/debian/rules')
-rwxr-xr-xubuntu/_base/dependencies/libart-lgpl/debian/rules30
1 files changed, 10 insertions, 20 deletions
diff --git a/ubuntu/_base/dependencies/libart-lgpl/debian/rules b/ubuntu/_base/dependencies/libart-lgpl/debian/rules
index 8ead6b1fc..9f7abd076 100755
--- a/ubuntu/_base/dependencies/libart-lgpl/debian/rules
+++ b/ubuntu/_base/dependencies/libart-lgpl/debian/rules
@@ -1,30 +1,20 @@
#!/usr/bin/make -f
include /usr/share/cdbs/1/rules/debhelper.mk
-#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
-include /usr/share/cdbs/1/rules/utils.mk
-include /usr/share/cdbs/1/class/gnome.mk
-
-debian/stamp-autoreconf:
- dh_testdir
- cp -Rp /usr/share/aclocal/libtool.m4 libtool.m4.in
-ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
- cp -Rp /usr/share/libtool/config/ltmain.sh ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
- cp -Rp /usr/share/libtool/build-aux/ltmain.sh ltmain.sh
-endif
- autoreconf -vi && \
- touch $@
-
-makebuilddir:: debian/stamp-autoreconf
- dh_testdir
+include /usr/share/cdbs/1/class/cmake.mk
libart-2.0-N := $(shell sed -rn 's/^Package:[[:space:]]*(libart-2\.0-[0-9]+)[[:space:]]*$$/\1/p' debian/control)
-GNOME_MODULE := libart_lgpl
-
DEB_DH_MAKESHLIBS_ARGS_$(libart-2.0-N) += -V '$(libart-2.0-N)(>= 2.3.18)'
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
+
+# Build options
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DWITH_ALL_OPTIONS="ON"
+
+DEB_MAKE_CHECK_TARGET = check