summaryrefslogtreecommitdiffstats
path: root/ubuntu/lucid_automake/applications/kmyfirewall/debian/rules
diff options
context:
space:
mode:
authorRobert Xu <robxu9@gmail.com>2012-02-21 19:27:13 -0500
committerRobert Xu <robxu9@gmail.com>2012-02-21 19:27:13 -0500
commit5d7b5e6defb05f81691d286d40f67260c4733d00 (patch)
treeb2bfcca86b05179cad334dc61c5609e54ac7674d /ubuntu/lucid_automake/applications/kmyfirewall/debian/rules
parent580ce2082fe5054c9ad0e4f666cee9b4bfb2d0b6 (diff)
parenta14ac9de2f5843036c9f452f1188979fef17ae6d (diff)
downloadtde-packaging-5d7b5e6defb05f81691d286d40f67260c4733d00.tar.gz
tde-packaging-5d7b5e6defb05f81691d286d40f67260c4733d00.zip
Merge branch 'master' of http://scm.trinitydesktop.org/scm/git/tde-packaging
Diffstat (limited to 'ubuntu/lucid_automake/applications/kmyfirewall/debian/rules')
-rwxr-xr-xubuntu/lucid_automake/applications/kmyfirewall/debian/rules8
1 files changed, 4 insertions, 4 deletions
diff --git a/ubuntu/lucid_automake/applications/kmyfirewall/debian/rules b/ubuntu/lucid_automake/applications/kmyfirewall/debian/rules
index e0333883c..61ad9e5cb 100755
--- a/ubuntu/lucid_automake/applications/kmyfirewall/debian/rules
+++ b/ubuntu/lucid_automake/applications/kmyfirewall/debian/rules
@@ -6,7 +6,7 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
-DEB_CONFIGURE_INCLUDEDIR := /opt/kde3/include/kde
+DEB_CONFIGURE_INCLUDEDIR := /opt/kde3/include/tde
DEB_CONFIGURE_MANDIR := /opt/kde3/share/man
DEB_CONFIGURE_PREFIX := /opt/kde3
DEB_CONFIGURE_INFODIR := /opt/kde3/share/info
@@ -56,7 +56,7 @@ endif
ifneq "$(wildcard /usr/share/misc/config.guess)" ""
cp -f /usr/share/misc/config.guess config.guess
endif
- CFLAGS="$(CFLAGS)" PATH=/opt/kde3/bin:$(PATH) CMAKE_LIBRARY_PATH=/opt/kde3/lib CMAKE_INCLUDE_PATH=/opt/kde3/include/kde ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) $(configkde) --prefix=/opt/kde3 --with-extra-libs=/opt/kde3/lib --with-extra-includes=/opt/kde3/include/kde
+ CFLAGS="$(CFLAGS)" PATH=/opt/kde3/bin:$(PATH) CMAKE_LIBRARY_PATH=/opt/kde3/lib CMAKE_INCLUDE_PATH=/opt/kde3/include/tde ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) $(configkde) --prefix=/opt/kde3 --with-extra-libs=/opt/kde3/lib --with-extra-includes=/opt/kde3/include/tde
build: build-stamp
@@ -65,7 +65,7 @@ build-stamp: config.status
dh_testdir
# Add here commands to compile the package.
- env PATH=/opt/kde3/bin:$(PATH) CMAKE_LIBRARY_PATH=/opt/kde3/lib CMAKE_INCLUDE_PATH=/opt/kde3/include/kde $(MAKE)
+ env PATH=/opt/kde3/bin:$(PATH) CMAKE_LIBRARY_PATH=/opt/kde3/lib CMAKE_INCLUDE_PATH=/opt/kde3/include/tde $(MAKE)
touch build-stamp
@@ -94,7 +94,7 @@ install: build
dh_clean -k
# Add here commands to install the package into debian/kmyfirewall.
- env PATH=/opt/kde3/bin:$(PATH) CMAKE_LIBRARY_PATH=/opt/kde3/lib CMAKE_INCLUDE_PATH=/opt/kde3/include/kde $(MAKE) install DESTDIR=$(CURDIR)/debian/kmyfirewall-kde3
+ env PATH=/opt/kde3/bin:$(PATH) CMAKE_LIBRARY_PATH=/opt/kde3/lib CMAKE_INCLUDE_PATH=/opt/kde3/include/tde $(MAKE) install DESTDIR=$(CURDIR)/debian/kmyfirewall-kde3
rm -f debian/kmyfirewall-kde3/opt/kde3/lib/*.so
chrpath -d debian/kmyfirewall-kde3/opt/kde3/bin/kmyfirewall debian/kmyfirewall-kde3/opt/kde3/lib/*.so.* debian/kmyfirewall-kde3/opt/kde3/lib/kde3/*.so