summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/applications/desktop-effects-kde/debian/rules
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2013-08-27 04:57:39 +0200
committerSlávek Banko <slavek.banko@axis.cz>2017-07-14 00:55:05 +0200
commit969208d92e57960ab67adf648474c3d8905ac0a6 (patch)
tree8c30f887bb530d429e8c0e406bb86312bae8ca46 /ubuntu/maverick/applications/desktop-effects-kde/debian/rules
parent0f086e717486c3aa5097a63d8ce3608d823a6f0c (diff)
downloadtde-packaging-969208d92e57960ab67adf648474c3d8905ac0a6.tar.gz
tde-packaging-969208d92e57960ab67adf648474c3d8905ac0a6.zip
Switch to dh_python2 (or dh_pysupport as fallback) on Debian and Ubuntu
(cherry picked from commit 2d0d0ba99b507cab093962cb910ddc7dd4755c94)
Diffstat (limited to 'ubuntu/maverick/applications/desktop-effects-kde/debian/rules')
-rwxr-xr-xubuntu/maverick/applications/desktop-effects-kde/debian/rules5
1 files changed, 4 insertions, 1 deletions
diff --git a/ubuntu/maverick/applications/desktop-effects-kde/debian/rules b/ubuntu/maverick/applications/desktop-effects-kde/debian/rules
index 8eee42e6a..25fa64a44 100755
--- a/ubuntu/maverick/applications/desktop-effects-kde/debian/rules
+++ b/ubuntu/maverick/applications/desktop-effects-kde/debian/rules
@@ -1,5 +1,8 @@
#!/usr/bin/make -f
+DEB_PYTHON_SYSTEM = $(if $(wildcard /usr/bin/dh_python2),,pysupport)
+DH_PYTHON2 = $(if $(wildcard /usr/bin/dh_python2),dh_python2,dh_pysupport)
+
include /usr/share/cdbs/1/rules/debhelper.mk
DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/kde
@@ -13,4 +16,4 @@ DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
binary-install/desktop-effects-kde-trinity::
- dh_pycentral -pdesktop-effects-kde-trinity
+ ${DH_PYTHON2} -pdesktop-effects-kde-trinity