summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/applications/k3b/debian/cdbs/debian-qt-kde.mk
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2016-03-12 18:11:22 +0100
committerSlávek Banko <slavek.banko@axis.cz>2016-03-12 18:11:51 +0100
commit88f8eed283f0bf40431774c0b368e0ae17d57b1d (patch)
tree7cd3dc314a5f91770b186530f58eed1c179c0d7c /ubuntu/maverick/applications/k3b/debian/cdbs/debian-qt-kde.mk
parent3e2017de7004da124f5ceb8d8709dc9f4cad8351 (diff)
downloadtde-packaging-88f8eed283f0bf40431774c0b368e0ae17d57b1d.tar.gz
tde-packaging-88f8eed283f0bf40431774c0b368e0ae17d57b1d.zip
Switch k3b to cmake on Debian and Ubuntu
Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit d702b5fdfebc11f747e1aeba0d88a1a7224dcd29)
Diffstat (limited to 'ubuntu/maverick/applications/k3b/debian/cdbs/debian-qt-kde.mk')
-rw-r--r--ubuntu/maverick/applications/k3b/debian/cdbs/debian-qt-kde.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/ubuntu/maverick/applications/k3b/debian/cdbs/debian-qt-kde.mk b/ubuntu/maverick/applications/k3b/debian/cdbs/debian-qt-kde.mk
index 9920696ce..32ba4acfb 100644
--- a/ubuntu/maverick/applications/k3b/debian/cdbs/debian-qt-kde.mk
+++ b/ubuntu/maverick/applications/k3b/debian/cdbs/debian-qt-kde.mk
@@ -10,6 +10,7 @@ _cdbs_class_debian-qt-kde := 1
# Note: This _must_ be included before autotools.mk, or it won't work.
common-configure-arch common-configure-indep:: debian/stamp-cvs-make
debian/stamp-cvs-make:
+ifndef _cdbs_class_cmake
cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
@@ -18,10 +19,11 @@ ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
cp -Rp /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
endif
$(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
+endif
touch debian/stamp-cvs-make
include debian/cdbs/kde.mk$(_cdbs_makefile_suffix)
-include debian/cdbs/uploaders.mk
+#include debian/cdbs/uploaders.mk
ifndef _cdbs_rules_patchsys_quilt
DEB_PATCHDIRS := debian/patches/common debian/patches
@@ -103,6 +105,7 @@ binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
done
clean::
+ifndef _cdbs_class_cmake
if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
cd $(DEB_SRCDIR); \
find . -name Makefile.in -print | \
@@ -111,6 +114,7 @@ clean::
configure configure.files configure.in stamp-h.in \
subdirs; \
fi
+endif
rm -f debian/stamp-cvs-make
endif