summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/applications/kdbg/debian/rules
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2013-07-08 22:26:06 +0200
committerSlávek Banko <slavek.banko@axis.cz>2013-07-08 22:28:33 +0200
commit207a28582aa5852a047a68048e9faee30b66f181 (patch)
tree82779233505468721babe44e1c5a8a69c0802aae /ubuntu/maverick/applications/kdbg/debian/rules
parentffa6d41b69b987312f21bacf094ca4c9adf90379 (diff)
downloadtde-packaging-207a28582aa5852a047a68048e9faee30b66f181.tar.gz
tde-packaging-207a28582aa5852a047a68048e9faee30b66f181.zip
Add packaging files for kdbg on Debian and Ubuntu
Diffstat (limited to 'ubuntu/maverick/applications/kdbg/debian/rules')
-rwxr-xr-xubuntu/maverick/applications/kdbg/debian/rules46
1 files changed, 46 insertions, 0 deletions
diff --git a/ubuntu/maverick/applications/kdbg/debian/rules b/ubuntu/maverick/applications/kdbg/debian/rules
new file mode 100755
index 000000000..814462bf3
--- /dev/null
+++ b/ubuntu/maverick/applications/kdbg/debian/rules
@@ -0,0 +1,46 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+
+#export DH_VERBOSE=1
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include debian/cdbs/kde.mk
+
+post-patches:: debian/stamp-bootstrap
+
+debian/stamp-bootstrap:
+ dh_testdir
+
+ # Regenerate build system
+ ! [ -f /usr/share/libtool/ltmain.sh ] || \
+ cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
+ ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
+ cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+ cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+
+ autoreconf --install && automake -f && \
+ $(MAKE) -f admin/Makefile.common && \
+ touch debian/stamp-bootstrap
+
+clean::
+ dh_testdir
+ rm -f debian/stamp-bootstrap
+
+install/kdbg-trinity::
+ dh_testdir
+
+ dh_install debian/kdbg.xpm opt/trinity/share/pixmaps
+
+ dh_installman debian/kdbg.1
+ mkdir -p debian/kdbg-trinity/opt/trinity/share/man
+ mv debian/kdbg-trinity/usr/share/man/man1 debian/kdbg-trinity/opt/trinity/share/man/
+ rmdir debian/kdbg-trinity/usr/share/man
+