summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/applications/tdeio-ftps/debian/cdbs
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2018-09-13 09:56:12 +0200
committerSlávek Banko <slavek.banko@axis.cz>2018-09-13 09:56:53 +0200
commitdc80df22b0b0cfbcffc970f8a6eddc00d6065866 (patch)
treeccc9057183384bd3e8143bd817c269a6da76bfa7 /ubuntu/maverick/applications/tdeio-ftps/debian/cdbs
parent27adce08c349d68142ecebd82a3d2721c6d58e35 (diff)
downloadtde-packaging-dc80df22b0b0cfbcffc970f8a6eddc00d6065866.tar.gz
tde-packaging-dc80df22b0b0cfbcffc970f8a6eddc00d6065866.zip
DEB tdeio-ftps: Switch to cmake
Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 35d5990302db69a9d3d60d7915b2e30194b37939)
Diffstat (limited to 'ubuntu/maverick/applications/tdeio-ftps/debian/cdbs')
-rw-r--r--ubuntu/maverick/applications/tdeio-ftps/debian/cdbs/debian-qt-kde.mk4
-rw-r--r--ubuntu/maverick/applications/tdeio-ftps/debian/cdbs/kde.mk4
2 files changed, 7 insertions, 1 deletions
diff --git a/ubuntu/maverick/applications/tdeio-ftps/debian/cdbs/debian-qt-kde.mk b/ubuntu/maverick/applications/tdeio-ftps/debian/cdbs/debian-qt-kde.mk
index b4b889c6d..32ba4acfb 100644
--- a/ubuntu/maverick/applications/tdeio-ftps/debian/cdbs/debian-qt-kde.mk
+++ b/ubuntu/maverick/applications/tdeio-ftps/debian/cdbs/debian-qt-kde.mk
@@ -10,6 +10,7 @@ _cdbs_class_debian-qt-kde := 1
# Note: This _must_ be included before autotools.mk, or it won't work.
common-configure-arch common-configure-indep:: debian/stamp-cvs-make
debian/stamp-cvs-make:
+ifndef _cdbs_class_cmake
cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
@@ -18,6 +19,7 @@ ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
cp -Rp /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
endif
$(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
+endif
touch debian/stamp-cvs-make
include debian/cdbs/kde.mk$(_cdbs_makefile_suffix)
@@ -103,6 +105,7 @@ binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
done
clean::
+ifndef _cdbs_class_cmake
if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
cd $(DEB_SRCDIR); \
find . -name Makefile.in -print | \
@@ -111,6 +114,7 @@ clean::
configure configure.files configure.in stamp-h.in \
subdirs; \
fi
+endif
rm -f debian/stamp-cvs-make
endif
diff --git a/ubuntu/maverick/applications/tdeio-ftps/debian/cdbs/kde.mk b/ubuntu/maverick/applications/tdeio-ftps/debian/cdbs/kde.mk
index 765560c89..023886fc8 100644
--- a/ubuntu/maverick/applications/tdeio-ftps/debian/cdbs/kde.mk
+++ b/ubuntu/maverick/applications/tdeio-ftps/debian/cdbs/kde.mk
@@ -35,7 +35,9 @@ else
DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
endif
+ifndef _cdbs_class_cmake
include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
+endif
export kde_cgidir = \$${libdir}/cgi-bin
export kde_confdir = \$${sysconfdir}/trinity
@@ -59,7 +61,7 @@ endif
cdbs_configure_flags += --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
-DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include/tde"
+DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%: