summaryrefslogtreecommitdiffstats
path: root/ubuntu/precise/applications/gtk-qt-engine/debian/rules
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2014-04-17 13:57:20 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2014-04-17 13:57:20 +0900
commit2d59086b104acd7b4711fd067c9bb4480158e6ab (patch)
tree7d3d9aff90930e65a491c055510aba94debc6da9 /ubuntu/precise/applications/gtk-qt-engine/debian/rules
parent55b519366b1dcd7ab5b2f1f720d275b33fc4bd49 (diff)
downloadtde-packaging-2d59086b104acd7b4711fd067c9bb4480158e6ab.tar.gz
tde-packaging-2d59086b104acd7b4711fd067c9bb4480158e6ab.zip
Removed Ubuntu/precise folder
Diffstat (limited to 'ubuntu/precise/applications/gtk-qt-engine/debian/rules')
-rwxr-xr-xubuntu/precise/applications/gtk-qt-engine/debian/rules37
1 files changed, 0 insertions, 37 deletions
diff --git a/ubuntu/precise/applications/gtk-qt-engine/debian/rules b/ubuntu/precise/applications/gtk-qt-engine/debian/rules
deleted file mode 100755
index 0aa6ab9a6..000000000
--- a/ubuntu/precise/applications/gtk-qt-engine/debian/rules
+++ /dev/null
@@ -1,37 +0,0 @@
-#!/usr/bin/make -f
-
-# Set LD_LIBRARY_PATH to the installed library directory to allow dh_shlibdeps to function
-# Also include the main Trinity path
-ifeq ("$(LD_LIBRARY_PATH)", "")
-LD_LIBRARY_PATH=/opt/trinity/lib:debian/tmp/opt/trinity/lib
-else
-LD_LIBRARY_PATH += :/opt/trinity/lib:debian/tmp/opt/trinity/lib
-endif
-export LD_LIBRARY_PATH
-
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/cmake.mk
-#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
-include /usr/share/cdbs/1/rules/utils.mk
-include debian/cdbs/debian-qt-kde.mk
-
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
-DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
-DEB_CONFIGURE_PREFIX := /opt/trinity
-DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
-
-cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
-
-DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib
-
-DEB_CMAKE_EXTRA_FLAGS := -DLIB_SUFFIX="" -DCMAKE_INSTALL_PREFIX="/opt/trinity" -DCONFIG_INSTALL_DIR="/etc/trinity" -DSYSCONF_INSTALL_DIR="/etc/trinity" -DCMAKE_LIBRARY_PATH="/opt/trinity/lib" -DCMAKE_INCLUDE_PATH="/opt/trinity/include/tde" -DAUTODETECT_QT_DIRS="ON" -DCMAKE_VERBOSE_MAKEFILE="ON" -DBUILD_ALL="ON" -DCMAKE_SKIP_RPATH="OFF" \
--DCMAKE_BUILD_TYPE=RelWithDebInfo
-
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
-
-binary-install/gtk-qt-engine-trinity::
- mkdir -p $(CURDIR)/debian/gtk-qt-engine-trinity/opt/trinity/share/kgtk/
- cp -Rp $(CURDIR)/debian/.gtkrc-2.0-kde4 $(CURDIR)/debian/gtk-qt-engine-trinity/opt/trinity/share/kgtk/
- cp -Rp $(CURDIR)/debian/.gtkrc-2.0-kde-kde4 $(CURDIR)/debian/gtk-qt-engine-trinity/opt/trinity/share/kgtk/
- cp -Rp $(CURDIR)/debian/gtk-qt-engine.rc.sh $(CURDIR)/debian/gtk-qt-engine-trinity/opt/trinity/share/kgtk/