summaryrefslogtreecommitdiffstats
path: root/ubuntu/precise/applications/kerry/debian/patches
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-09-10 16:16:32 -0500
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-09-10 16:16:32 -0500
commit02dc85a95b228b7242b0d11ea35619faad96db03 (patch)
treee161ba877a0720bbdf7818bdec06eb239d8ad271 /ubuntu/precise/applications/kerry/debian/patches
parent6f2c7dc70e77d2f768d687838b6cc9f7632f609e (diff)
downloadtde-packaging-02dc85a95b228b7242b0d11ea35619faad96db03.tar.gz
tde-packaging-02dc85a95b228b7242b0d11ea35619faad96db03.zip
Split precise from maverick
Diffstat (limited to 'ubuntu/precise/applications/kerry/debian/patches')
-rw-r--r--ubuntu/precise/applications/kerry/debian/patches/kubuntu_03_no_beagle_autostart.patch12
-rw-r--r--ubuntu/precise/applications/kerry/debian/patches/kubuntu_04_no_core_kmenu_entry.desktop.patch19
-rw-r--r--ubuntu/precise/applications/kerry/debian/patches/kubuntu_05_shortkey.patch13
3 files changed, 44 insertions, 0 deletions
diff --git a/ubuntu/precise/applications/kerry/debian/patches/kubuntu_03_no_beagle_autostart.patch b/ubuntu/precise/applications/kerry/debian/patches/kubuntu_03_no_beagle_autostart.patch
new file mode 100644
index 000000000..8119d9cc4
--- /dev/null
+++ b/ubuntu/precise/applications/kerry/debian/patches/kubuntu_03_no_beagle_autostart.patch
@@ -0,0 +1,12 @@
+diff -Nur kerry-0.2.1/kerry/src/Makefile.am kerry-0.2.1.new/kerry/src/Makefile.am
+--- kerry-0.2.1/kerry/src/Makefile.am 2006-12-05 18:28:31.000000000 +0100
++++ kerry-0.2.1.new/kerry/src/Makefile.am 2006-12-05 18:28:53.000000000 +0100
+@@ -31,7 +31,7 @@
+ kerry_la_LIBADD = -lkio -lkonq $(LIB_TDEUI) $(LIBBEAGLE_LIBADD) $(GLIB_LIBADD) $(LIB_KABC) -lDCOP $(LIB_QT) $(LIB_TDECORE)
+
+ autostartdir = $(datadir)/autostart
+-autostart_DATA = kerry.autostart.desktop beagled.desktop
++autostart_DATA = kerry.autostart.desktop
+
+ shutdowndir = $(prefix)/bin
+ shutdown_SCRIPTS = beagled-shutdown
diff --git a/ubuntu/precise/applications/kerry/debian/patches/kubuntu_04_no_core_kmenu_entry.desktop.patch b/ubuntu/precise/applications/kerry/debian/patches/kubuntu_04_no_core_kmenu_entry.desktop.patch
new file mode 100644
index 000000000..896193aba
--- /dev/null
+++ b/ubuntu/precise/applications/kerry/debian/patches/kubuntu_04_no_core_kmenu_entry.desktop.patch
@@ -0,0 +1,19 @@
+diff -Nur -x '*.orig' -x '*~' kerry-0.2.1/kerry/src/kerry.desktop kerry-0.2.1.new/kerry/src/kerry.desktop
+--- kerry-0.2.1/kerry/src/kerry.desktop 2006-12-04 14:35:38.000000000 +0100
++++ kerry-0.2.1.new/kerry/src/kerry.desktop 2008-04-08 22:55:31.000000000 +0200
+@@ -1,6 +1,5 @@
+ [Desktop Entry]
+ X-SuSE-translate=true
+-Encoding=UTF-8
+ Name=Kerry Beagle
+ GenericName=Desktop Search
+ GenericName[ar]=بحث على سطح المكتب
+@@ -25,7 +24,7 @@
+ Exec=kerry --show-searchdialog
+ Icon=kerry
+ Type=Application
+-Categories=Qt;TDE;Application;Core;Utility;Filesystem;
++Categories=Qt;TDE;Application;Utility;Filesystem;
+ Terminal=false
+ X-DCOP-ServiceType=Unique
+ X-TDE-StartupNotify=false
diff --git a/ubuntu/precise/applications/kerry/debian/patches/kubuntu_05_shortkey.patch b/ubuntu/precise/applications/kerry/debian/patches/kubuntu_05_shortkey.patch
new file mode 100644
index 000000000..d7f3f3649
--- /dev/null
+++ b/ubuntu/precise/applications/kerry/debian/patches/kubuntu_05_shortkey.patch
@@ -0,0 +1,13 @@
+diff -Nur kerry-0.2.1/kerry/src/kerryapp.cpp kerry-0.2.1.new/kerry/src/kerryapp.cpp
+--- kerry-0.2.1/kerry/src/kerryapp.cpp
++++ kerry-0.2.1.new/kerry/src/kerryapp.cpp
+@@ -122,8 +122,7 @@
+ globalKeys = new KGlobalAccel(TQT_TQOBJECT(this));
+ globalKeys->insert( "Program:kerry", i18n("Kerry Beagle Search") );
+
+- KShortcut showDialogShortcut = KShortcut(ALT+Key_Space);
+- showDialogShortcut.append( KKey( Key_F12 ) );
++ KShortcut showDialogShortcut = KShortcut(CTRL+SHIFT+Key_Space);
+ globalKeys->insert( "Show Kerry Dialog", i18n("Show Search Dialog"), TQString(), showDialogShortcut, showDialogShortcut, TQT_TQOBJECT(hitListWindow), TQT_SLOT(showSearchDialog()) );
+ globalKeys->insert( "Search Primary Selection with Kerry", i18n("Search Primary Selection"), TQString(), CTRL+ALT+Key_Space, CTRL+ALT+Key_Space, TQT_TQOBJECT(this), TQT_SLOT(searchPrimarySelection()) );
+ configChanged();