summaryrefslogtreecommitdiffstats
path: root/ubuntu/precise/applications/knmap/debian/rules
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-07-24 11:37:37 -0500
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-07-24 11:40:05 -0500
commit12921402bed782c15887660b49b809f31861b574 (patch)
tree34a9713315589d28668ff5d15c41fb8b7d449586 /ubuntu/precise/applications/knmap/debian/rules
parentf83e249eac526497a2c3a7e1aa100b78e57f9bfa (diff)
downloadtde-packaging-12921402bed782c15887660b49b809f31861b574.tar.gz
tde-packaging-12921402bed782c15887660b49b809f31861b574.zip
Add preliminary knmap packaging files for Debian and Ubuntu
Diffstat (limited to 'ubuntu/precise/applications/knmap/debian/rules')
-rwxr-xr-xubuntu/precise/applications/knmap/debian/rules31
1 files changed, 31 insertions, 0 deletions
diff --git a/ubuntu/precise/applications/knmap/debian/rules b/ubuntu/precise/applications/knmap/debian/rules
new file mode 100755
index 000000000..1612bbf8a
--- /dev/null
+++ b/ubuntu/precise/applications/knmap/debian/rules
@@ -0,0 +1,31 @@
+#!/usr/bin/make -f
+
+cdbs_kde_enable_debug = --disable-debug
+
+include /usr/share/cdbs/1/rules/simple-patchsys.mk
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/kde.mk
+
+DEB_INSTALL_MANPAGES_knmap-trinity = knmap.1
+
+post-patches::
+ # regenerating files to build app
+ $(MAKE) -f Makefile.cvs
+
+install/knmap-trinity::
+ dh_install src/knmap.desktop usr/share/applications/tde
+ dh_link opt/trinity/share/doc/tde/HTML/en/knmap usr/share/doc/knmap/html
+ dh_iconcache
+
+build/knmap-trinity::
+ docbook2x-man debian/knmap.1.docbook
+
+clean::
+ rm -f knmap.1
+ # removing files not cleaned by upstream
+ rm -f doc/en/Makefile.in
+ rm -f src/Makefile.in
+ rm -f configure
+ rm -f Makefile.in
+ rm -f subdirs
+ rm -f aclocal.m4