summaryrefslogtreecommitdiffstats
path: root/arch/3.5.13/trinity-base/trinity-tqtinterface/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'arch/3.5.13/trinity-base/trinity-tqtinterface/PKGBUILD')
-rw-r--r--arch/3.5.13/trinity-base/trinity-tqtinterface/PKGBUILD28
1 files changed, 22 insertions, 6 deletions
diff --git a/arch/3.5.13/trinity-base/trinity-tqtinterface/PKGBUILD b/arch/3.5.13/trinity-base/trinity-tqtinterface/PKGBUILD
index 8d6647d14..2a12c76d5 100644
--- a/arch/3.5.13/trinity-base/trinity-tqtinterface/PKGBUILD
+++ b/arch/3.5.13/trinity-base/trinity-tqtinterface/PKGBUILD
@@ -14,14 +14,13 @@ makedepends=('pkgconfig' 'cmake')
conflicts=('kdemod3-tqtinterface')
makeopts=('libtool' '!emptydirs')
source=('http://mirror.ets.kth.se/trinity/releases/3.5.13/dependencies/tqtinterface-3.5.13.tar.gz'
- 'tqtpc-location.patch')
+ 'tqtpc-location.patch' 'trinity.profile.sh' 'trinity.profile.csh')
md5sums=('d54cc9fd0b35555298efd17c32471a2b'
- 'c15745c944d98cb7c4cb553f0ca421d4')
+ 'c15745c944d98cb7c4cb553f0ca421d4'
+ '72c6c4fb492c1f4b4741fad1dd70d62f'
+ '915e14c6264a6b9c46a6a20b16cdcd06')
install='trinity-tqtinterface.install'
-# istead of using prefix, we will use QTDIR from qt3 profile
-_prefix=/opt/trinity
-
build() {
msg "Setting PATH, CMAKE and Trinity Environment variables"
# Source the QT and KDE profile
@@ -34,7 +33,7 @@ build() {
msg "Starting cmake..."
cmake "../dependencies/tqtinterface" \
- -DCMAKE_INSTALL_PREFIX=${_prefix} \
+ -DCMAKE_INSTALL_PREFIX=/opt/trinity \
-DQT_PREFIX_DIR=${QTDIR} \
-DQT_INCLUDE_DIR=${QTDIR}/include \
-DMOC_EXECUTABLE=${QTDIR}/bin/moc \
@@ -56,4 +55,21 @@ package() {
#mkdir -p ${pkgdir}/usr/bin
#cp -Rp ${srcdir}/${_svnmod}/qtinterface/uic-tqt ${pkgdir}/usr/bin
+ # it should contain sripts which would add
+ # their location into system variables
+ # this mean that this package should provide
+ # /etc/ld.so.conf.d/trinity.conf - lib locations for linker
+ # /etc/profile.d/trinity.sh - $PATH and other system variables for bash
+ # /etc/profile.d/trinity.csh - $PATH and other system variables for csh
+ # up until now it was done in the kdelibs PKGBUILD/package
+
+ # Create and install ld.so.conf.d file
+ install -d -m755 $pkgdir/etc/ld.so.conf.d/
+ echo $TDEDIR/lib > $pkgdir/etc/ld.so.conf.d/trinity.conf
+ echo $TDEDIR/lib/trinity >> $pkgdir/etc/ld.so.conf.d/trinity.conf
+
+ # Install profiles
+ install -D -m755 $srcdir/trinity.profile.sh $pkgdir/etc/profile.d/trinity.sh
+ install -D -m755 $srcdir/trinity.profile.csh $pkgdir/etc/profile.d/trinity.csh
+
}