summaryrefslogtreecommitdiffstats
path: root/debian/wheezy/dependencies/tqtinterface
diff options
context:
space:
mode:
Diffstat (limited to 'debian/wheezy/dependencies/tqtinterface')
-rwxr-xr-xdebian/wheezy/dependencies/tqtinterface/debian/rules3
-rw-r--r--debian/wheezy/dependencies/tqtinterface/debian/source/options4
2 files changed, 5 insertions, 2 deletions
diff --git a/debian/wheezy/dependencies/tqtinterface/debian/rules b/debian/wheezy/dependencies/tqtinterface/debian/rules
index f05e2fadd..5d8f4cb4c 100755
--- a/debian/wheezy/dependencies/tqtinterface/debian/rules
+++ b/debian/wheezy/dependencies/tqtinterface/debian/rules
@@ -14,6 +14,9 @@ DEB_OPT_FLAG += -DDEBIAN_VERSION=$(DEB_VERSION)
DEB_CMAKE_EXTRA_FLAGS := -DPKGCONFIG_INSTALL_DIR="/usr/lib/pkgconfig" -DLIB_SUFFIX="" -DCMAKE_INSTALL_PREFIX="/usr" -DCMAKE_LIBRARY_PATH="/usr/lib" -DCMAKE_INCLUDE_PATH="/usr/include" -DCMAKE_VERBOSE_MAKEFILE="ON" -DWITH_QT3="ON" -DQTDIR="/usr/share/qt3" -DQT_LIBRARY_DIRS="/usr/share/qt3/lib" -DBUILD_ALL="ON" -DUSE_QT3="ON" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
# Honour "parallel=N" option of DEB_BUILD_OPTIONS. Comment out to
# never build in parallel, regardless of DEB_BUILD_OPTIONS.
DEB_BUILD_PARALLEL = true
diff --git a/debian/wheezy/dependencies/tqtinterface/debian/source/options b/debian/wheezy/dependencies/tqtinterface/debian/source/options
index 9d7c8e036..72f1f5450 100644
--- a/debian/wheezy/dependencies/tqtinterface/debian/source/options
+++ b/debian/wheezy/dependencies/tqtinterface/debian/source/options
@@ -1,5 +1,5 @@
-# Use bzip2 instead of gzip
-compression = "bzip2"
+# Use xz instead of gzip
+compression = "xz"
compression-level = 9
# Don't run differences