summaryrefslogtreecommitdiffstats
path: root/dilos/dependencies/pytqt/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'dilos/dependencies/pytqt/debian/rules')
-rwxr-xr-xdilos/dependencies/pytqt/debian/rules34
1 files changed, 7 insertions, 27 deletions
diff --git a/dilos/dependencies/pytqt/debian/rules b/dilos/dependencies/pytqt/debian/rules
index 730a3e36f..2db7dbaaf 100755
--- a/dilos/dependencies/pytqt/debian/rules
+++ b/dilos/dependencies/pytqt/debian/rules
@@ -3,8 +3,6 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
-DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
-
# The default gzip compressor has been changed in dpkg >= 1.17.0.
deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
sed -e "s|.*version ||" -e "s| .*||" | \
@@ -15,9 +13,13 @@ DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
endif
+export DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
+export DEB_HOST_ARCH_CPU ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_CPU)
+export DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
+
export DH_OPTIONS
--include /usr/share/python/python.mk
+-include /usr/share/python3/python.mk
ifeq (,$(py_sitename))
py_sitename = site-packages
py_libdir = /usr/lib/python$(subst python,,$(1))/site-packages
@@ -39,10 +41,7 @@ else
endif
CXXFLAGS += "-I/usr/include/tqt"
-PYTHONS := $(shell pyversions -vr debian/control) $(shell py3versions -vd)
-
-DEB_PYTHON_SYSTEM = $(if $(wildcard /usr/bin/dh_python2),,pysupport)
-DH_PYTHON2 = $(if $(wildcard /usr/bin/dh_python2),dh_python2,dh_pysupport)
+PYTHONS := $(shell py3versions -vd)
DEB_PARALLEL_JOBS ?= 40
@@ -141,19 +140,6 @@ install-arch-3.%:
# mv debian/python3-pytqt-dbg/usr/lib/python3.$*/$(call py_sitename,$$version)/PyTQt/qtext.so \
# debian/python3-pytqtext-dbg/usr/lib/python3.$*/$(call py_sitename,$$version)/PyTQt/
-install-arch-%:
- $(MAKE) -C build-$* install DESTDIR=$(CURDIR)/debian/tmp
-# $(MAKE) -C dbg-build-$* install DESTDIR=$(CURDIR)/debian/python-pytqt-dbg
- mkdir -p debian/python-pytqt/usr/lib/python$*/$(call py_sitename,$$version)/PyTQt
- cp -a debian/tmp/usr/lib/python$*/$(call py_sitename,$$version)/PyTQt/__init__.py \
- debian/python-pytqt/usr/lib/python$*/$(call py_sitename,$$version)/PyTQt/__init__.py
-# mkdir -p debian/python-pytqt-gl-dbg/usr/lib/python$*/$(call py_sitename,$$version)/PyTQt
-# mv debian/python-pytqt-dbg/usr/lib/python$*/$(call py_sitename,$$version)/PyTQt/qtgl.so \
-# debian/python-pytqt-gl-dbg/usr/lib/python$*/$(call py_sitename,$$version)/PyTQt/
-# mkdir -p debian/python-pytqtext-dbg/usr/lib/python$*/$(call py_sitename,$$version)/PyTQt
-# mv debian/python-pytqt-dbg/usr/lib/python$*/$(call py_sitename,$$version)/PyTQt/qtext.so \
-# debian/python-pytqtext-dbg/usr/lib/python$*/$(call py_sitename,$$version)/PyTQt/
-
clean:
dh_testdir
dh_testroot
@@ -175,14 +161,8 @@ binary-common:
# dh_strip
dh_compress -X.py -X.bmp -X.ui -X.sql
dh_fixperms
-ifneq (dh_pysupport,${DH_PYTHON2})
- ${DH_PYTHON2} --no-dbg-cleaning
-else
- ${DH_PYTHON2}
-endif
dh_python3 --no-dbg-cleaning
- dh_sip_tqt
- dh_sip3_tqt
+ dh_py3sip_tqt
dh_lintian
dh_installdeb
dh_shlibdeps --dpkg-shlibdeps-params=--ignore-missing-info