summaryrefslogtreecommitdiffstats
path: root/redhat/applications/amarok/amarok-14.0.0.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/applications/amarok/amarok-14.0.0.spec')
-rw-r--r--redhat/applications/amarok/amarok-14.0.0.spec11
1 files changed, 10 insertions, 1 deletions
diff --git a/redhat/applications/amarok/amarok-14.0.0.spec b/redhat/applications/amarok/amarok-14.0.0.spec
index ae7735a4e..3d88d4962 100644
--- a/redhat/applications/amarok/amarok-14.0.0.spec
+++ b/redhat/applications/amarok/amarok-14.0.0.spec
@@ -1,5 +1,5 @@
#
-# spec file for package amarok (version R14.0.0)
+# spec file for package amarok (version R14)
#
# Copyright (c) 2014 Trinity Desktop Environment
#
@@ -17,7 +17,9 @@
# TDE variables
%define tde_epoch 2
+%if "%{?tde_version}" == ""
%define tde_version 14.0.0
+%endif
%define tde_pkg amarok
%define tde_prefix /opt/trinity
%define tde_bindir %{tde_prefix}/bin
@@ -419,6 +421,13 @@ use any of xmms' visualisation plugins with Amarok.
%prep
%setup -q -n %{name}-%{tde_version}%{?preversion:~%{preversion}}
+# Fix some Ruby stuff
+if ! ruby -rrbconfig -e "puts Config.expand( Config::MAKEFILE_CONFIG['MAJOR'] )" &>/dev/null; then
+ %__sed -i "amarok/src/mediadevice/daap/ConfigureChecks.cmake" \
+ -e "s|Config::|RbConfig::|g" \
+ -e "s|Config\.|RbConfig\.|g"
+fi
+
%build
unset QTDIR QTINC QTLIB