summaryrefslogtreecommitdiffstats
path: root/redhat/applications/kscope/kscope-14.0.0.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/applications/kscope/kscope-14.0.0.spec')
-rw-r--r--redhat/applications/kscope/kscope-14.0.0.spec113
1 files changed, 74 insertions, 39 deletions
diff --git a/redhat/applications/kscope/kscope-14.0.0.spec b/redhat/applications/kscope/kscope-14.0.0.spec
index 8af7b3b83..c684c1e6e 100644
--- a/redhat/applications/kscope/kscope-14.0.0.spec
+++ b/redhat/applications/kscope/kscope-14.0.0.spec
@@ -1,42 +1,61 @@
-# Default version for this component
-%define tde_pkg kscope
+#
+# spec file for package kscope (version R14)
+#
+# Copyright (c) 2014 Trinity Desktop Environment
+#
+# All modifications and additions to the file contributed by third parties
+# remain the property of their copyright owners, unless otherwise agreed
+# upon. The license for this file, and modifications and additions to the
+# file, is the same license as for the pristine package itself (unless the
+# license for the pristine package is not an Open Source License, in which
+# case the license is the MIT License). An "Open Source License" is a
+# license that conforms to the Open Source Definition (Version 1.9)
+# published by the Open Source Initiative.
+#
+# Please submit bugfixes or comments via http://www.trinitydesktop.org/
+#
+
+# TDE variables
+%define tde_epoch 2
+%if "%{?tde_version}" == ""
%define tde_version 14.0.0
-
-# If TDE is built in a specific prefix (e.g. /opt/trinity), the release will be suffixed with ".opt".
-%if "%{?tde_prefix}" != "/usr"
-%define _variant .opt
%endif
-
-# TDE specific building variables
+%define tde_pkg kscope
+%define tde_prefix /opt/trinity
%define tde_bindir %{tde_prefix}/bin
%define tde_datadir %{tde_prefix}/share
%define tde_docdir %{tde_datadir}/doc
%define tde_includedir %{tde_prefix}/include
%define tde_libdir %{tde_prefix}/%{_lib}
%define tde_mandir %{tde_datadir}/man
-
%define tde_tdeappdir %{tde_datadir}/applications/tde
%define tde_tdedocdir %{tde_docdir}/tde
%define tde_tdeincludedir %{tde_includedir}/tde
%define tde_tdelibdir %{tde_libdir}/trinity
-%define _docdir %{tde_docdir}
+Name: trinity-%{tde_pkg}
+Epoch: %{tde_epoch}
+Version: 1.6.2
+Release: %{?tde_version}_%{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}
+Summary: Source editing environment for TDE
+Group: Applications/Internet
+URL: http://kscope.sourceforge.net
+
+%if 0%{?suse_version}
+License: GPL-2.0+
+%else
+License: GPLv2+
+%endif
-Name: trinity-%{tde_pkg}
-Version: 1.6.2
-Release: %{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}%{?_variant}
-Summary: source editing environment for TDE
+#Vendor: Trinity Desktop
+#Packager: Francois Andriot <francois.andriot@free.fr>
-Group: Applications/Internet
-License: GPLv2+
-URL: http://kscope.sourceforge.net
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+Prefix: %{tde_prefix}
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Source0: %{name}-%{tde_version}%{?preversion:~%{preversion}}.tar.gz
-BuildRequires: trinity-tqtinterface-devel >= %{tde_version}
-BuildRequires: trinity-arts-devel >= 1:1.5.10
BuildRequires: trinity-tdelibs-devel >= %{tde_version}
BuildRequires: trinity-tdebase-devel >= %{tde_version}
BuildRequires: desktop-file-utils
@@ -44,6 +63,25 @@ BuildRequires: desktop-file-utils
BuildRequires: gettext
Requires: cscope
+BuildRequires: autoconf automake libtool m4
+BuildRequires: gcc-c++
+BuildRequires: pkgconfig
+BuildRequires: fdupes
+
+# SUSE desktop files utility
+%if 0%{?suse_version}
+BuildRequires: update-desktop-files
+%endif
+
+%if 0%{?opensuse_bs} && 0%{?suse_version}
+# for xdg-menu script
+BuildRequires: brp-check-trinity
+%endif
+
+BuildRequires: flex
+BuildRequires: bison
+
+
%description
KScope is a TDE front-end to Cscope. It provides a source-editing environment
for large C projects. KScope is focused on source editing and analysis.
@@ -73,16 +111,20 @@ Main Features:
* Works with externally-built cscope.out files
-%if 0%{?suse_version} || 0%{?pclinuxos}
+##########
+
+%if 0%{?pclinuxos} || 0%{?suse_version} && 0%{?opensuse_bs} == 0
%debug_package
%endif
+##########
+
%prep
%setup -q -n %{name}-%{tde_version}%{?preversion:~%{preversion}}
%__cp -f "/usr/share/aclocal/libtool.m4" "admin/libtool.m4.in"
-%__cp -f "/usr/share/libtool/config/ltmain.sh" "admin/ltmain.sh" || %__cp -f "/usr/share/libtool/ltmain.sh" "admin/ltmain.sh"
+%__cp -f "/usr/share/libtool/"*"/ltmain.sh" "admin/ltmain.sh" || %__cp -f "/usr/share/libtool/ltmain.sh" "admin/ltmain.sh"
%__make -f "admin/Makefile.common"
@@ -116,30 +158,25 @@ export PATH="%{tde_bindir}:${PATH}"
%find_lang %{tde_pkg}
+# Move desktop icon to correct location
+%__mkdir_p "%{?buildroot}%{tde_tdeappdir}"
+%__mv -f "%{?buildroot}%{tde_datadir}/applnk/"*"/%{tde_pkg}.desktop" "%{?buildroot}%{tde_tdeappdir}"
-%clean
-%__rm -rf $RPM_BUILD_ROOT
-
-
-%post
-for i in hicolor locolor ; do
- touch --no-create %{tde_datadir}/icons/$i 2>/dev/null || :
- gtk-update-icon-cache --quiet %{tde_datadir}/icons/$i 2>/dev/null || :
-done
+# Updates applications categories for openSUSE
+%if 0%{?suse_version}
+%suse_update_desktop_file %{tde_pkg} Development IDE
+%endif
-%postun
-for i in hicolor locolor ; do
- touch --no-create %{tde_datadir}/icons/$i 2>/dev/null || :
- gtk-update-icon-cache --quiet %{tde_datadir}/icons/$i 2>/dev/null || :
-done
+%clean
+%__rm -rf $RPM_BUILD_ROOT
%files -f %{tde_pkg}.lang
%defattr(-,root,root,-)
%doc AUTHORS COPYING README ChangeLog
%{tde_bindir}/kscope
-%{tde_datadir}/applnk/Development/kscope.desktop
+%{tde_tdeappdir}/kscope.desktop
%{tde_datadir}/apps/kscope/
%{tde_tdedocdir}/HTML/en/kscope/
%{tde_datadir}/icons/hicolor/*/apps/kscope.png
@@ -147,5 +184,3 @@ done
%changelog
-* Fri Jul 05 2013 Francois Andriot <francois.andriot@free.fr> - 1.6.2-1
-- Initial release for TDE 14.0.0