summaryrefslogtreecommitdiffstats
path: root/redhat/applications/multimedia/k3b/k3b.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/applications/multimedia/k3b/k3b.spec')
-rw-r--r--redhat/applications/multimedia/k3b/k3b.spec52
1 files changed, 47 insertions, 5 deletions
diff --git a/redhat/applications/multimedia/k3b/k3b.spec b/redhat/applications/multimedia/k3b/k3b.spec
index 47e6720a5..ddbdf76df 100644
--- a/redhat/applications/multimedia/k3b/k3b.spec
+++ b/redhat/applications/multimedia/k3b/k3b.spec
@@ -77,13 +77,26 @@ BuildRequires: update-desktop-files
BuildRequires: brp-check-trinity
%endif
-BuildRequires: alsa-lib-devel
+# ALSA supportl
+%if 0%{?mdkver}
+BuildRequires: %{_lib}asound-devel
+%else
+BuildRequires: alsa-lib-devel
+%endif
+
BuildRequires: audiofile-devel
BuildRequires: gettext
-BuildRequires: libvorbis-devel
BuildRequires: taglib-devel
BuildRequires: zlib-devel
+# VORBIS support
+%if 0%{?mdkver} || 0%{?mgaversion}
+%define libvorbis_devel %{_lib}vorbis-devel
+%else
+%define libvorbis_devel libvorbis-devel
+%endif
+BuildRequires: %{libvorbis_devel}
+
# IDN support
BuildRequires: libidn-devel
@@ -95,13 +108,26 @@ BuildRequires: gamin-devel
%endif
# OPENSSL support
+%if 0%{?mdkver}
+BuildRequires: %{_lib}openssl-devel
+%else
BuildRequires: openssl-devel
+%endif
# ACL support
+%if 0%{?mdkver}
+BuildRequires: %{_lib}acl-devel
+%else
BuildRequires: libacl-devel
+%endif
# ATTR support
-BuildRequires: libattr-devel
+%if 0%{?mgaversion} || 0%{?mdkversion}
+%define libattr_devel %{_lib}attr-devel
+%else
+%define libattr_devel libattr-devel
+%endif
+BuildRequires: %{libattr_devel}
Requires(post): coreutils
Requires(postun): coreutils
@@ -125,8 +151,12 @@ Requires: cdrdao
# UDEV support
%if 0%{?fedora} || 0%{?mdkversion} || 0%{?mgaversion} || 0%{?suse_version} || 0%{?rhel} >= 6
+%if 0%{?mdkversion} || 0%{?mgaversion}
+BuildRequires: %{_lib}udev-devel
+%else
BuildRequires: libudev-devel
%endif
+%endif
# HAL support
%if 0%{?rhel} == 5
@@ -148,13 +178,21 @@ Requires: trinity-dbus-tqt >= 1:0.63
# SNDFILE support
%if 0%{?mdkversion} || 0%{?mgaversion} || 0%{?fedora} || 0%{?suse_version} || 0%{?rhel} >= 4
%define with_sndfile 1
+%if 0%{?mdkversion} || 0%{?mgaversion}
+BuildRequires: %{_lib}sndfile-devel
+%else
BuildRequires: libsndfile-devel
%endif
+%endif
# SAMPLERATE support
%if 0%{?mdkversion} || 0%{?mgaversion} || 0%{?fedora} || 0%{?suse_version} || 0%{?rhel} >= 4
%define with_samplerate 1
-BuildRequires: libsamplerate-devel
+%if 0%{?mdkversion} || 0%{?mgaversion}
+BuildRequires: %{_lib}samplerate-devel
+%else
+BuildRequires: libsamplerate-devel
+%endif
%endif
# DVDREAD support
@@ -230,8 +268,12 @@ BuildRequires: ffmpeg-devel
%if 0%{?fedora} == 0 || 0%{?fedora} <= 37
# Looking for mpc_decoder_setup in mpcdec - not found
%define with_musepack 1
+%if 0%{?mdkversion} || 0%{?mgaversion}
+BuildRequires: %{_lib}mpcdec-devel
+%else
BuildRequires: libmpcdec-devel
%endif
+%endif
%description
@@ -434,7 +476,7 @@ export PKG_CONFIG_PATH="%{tde_libdir}/pkgconfig:${PKG_CONFIG_PATH}"
RPM_OPT_FLAGS="${RPM_OPT_FLAGS} -std=c++11"
%endif
-if ! rpm -E %%cmake|grep -q "cd build"; then
+if ! rpm -E %%cmake|grep -e 'cd build\|cd ${CMAKE_BUILD_DIR:-build}'; then
%__mkdir_p build
cd build
fi