summaryrefslogtreecommitdiffstats
path: root/redhat/applications/office/koffice/koffice.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/applications/office/koffice/koffice.spec')
-rw-r--r--redhat/applications/office/koffice/koffice.spec21
1 files changed, 11 insertions, 10 deletions
diff --git a/redhat/applications/office/koffice/koffice.spec b/redhat/applications/office/koffice/koffice.spec
index 4f8b19a34..9ec132b50 100644
--- a/redhat/applications/office/koffice/koffice.spec
+++ b/redhat/applications/office/koffice/koffice.spec
@@ -46,7 +46,7 @@
%global _normalized_cpu %(echo %{_target_cpu} | sed 's/^ppc/powerpc/;s/i.86/i386/;s/sparcv./sparc/;s/armv.*/arm/')
# Required for Mageia 2: removes the ldflag '--no-undefined'
-%define _disable_ld_no_undefined 1
+%global _disable_ld_no_undefined 1
Name: trinity-%{tde_pkg}
@@ -210,7 +210,7 @@ BuildRequires: freetype-devel
%if 0%{?mdkver} || 0%{?mgaversion}
BuildRequires: %{_lib}png-devel
%endif
-%if 0%{?mdkversion} && 0%{?mdkver} == 0 && 0%{?pclinuxos} == 0
+%if 0%{?mdkversion} && 0%{?mdkver} < 24090000 && 0%{?pclinuxos} == 0
BuildRequires: %{_lib}png15-devel
%endif
%if 0%{?suse_version} || 0%{?fedora} || 0%{?rhel}
@@ -293,7 +293,7 @@ Obsoletes: trinity-libwpd < %{?epoch:%{epoch}:}%{version}-%{release}
# WV2 support
%if 0%{?mgaversion} || 0%{?mdkversion}
-%if 0%{?mdkver} == 0
+%if 0%{?mdkver} < 24090000
BuildRequires: %{_lib}wv2-devel
%endif
%endif
@@ -303,10 +303,10 @@ BuildRequires: wv2-devel
# MESA support
%if 0%{?mgaversion} || 0%{?mdkversion}
-%if 0%{?mdkver} == 0 && 0%{?pclinuxos} == 0
+%if 0%{?mdkver} < 24090000 && 0%{?pclinuxos} == 0
BuildRequires: %{_lib}mesagl-devel
%endif
-%if 0%{?mdkver}
+%if 0%{?mdkver} >= 24090000
BuildRequires: %{_lib}glu-devel
%else
BuildRequires: %{_lib}mesaglu1-devel
@@ -1189,6 +1189,12 @@ CXXFLAGS="${CXXFLAGS} -std=c++11"
%{?with_kross:--enable-scripting} %{!?with_kross:--disable-scripting} \
%{?with_postgresql:--enable-pgsql} %{!?with_postgresql:--disable-pgsql} \
+%if %{?with_postgresql}
+# Ensure PQXX was detected
+
+
+%endif
+
%__make %{?_smp_mflags} || %__make
@@ -1196,11 +1202,6 @@ CXXFLAGS="${CXXFLAGS} -std=c++11"
%__rm -rf %{buildroot}
%__make install DESTDIR=%{buildroot}
-#%__mkdir_p "%{buildroot}%{tde_datadir}/icons/hicolor/{16x16,22x22,32x32,48x48,64x64,128x128}/apps/"
-#for i in {16x16,22x22,32x32,48x48,64x64,128x128}; do
-# mv "%{buildroot}%{tde_datadir}/icons/crystalsvg/$i/apps/kplato.png %{buildroot}/opt/kde3/share/icons/hicolor/$i/apps/;
-#done
-
# Fix desktop icon location
%__mv -f "%{?buildroot}%{tde_datadir}/applnk/"*"/KThesaurus.desktop" "%{?buildroot}%{tde_tdeappdir}"