summaryrefslogtreecommitdiffstats
path: root/redhat/applications/office/kpilot/kpilot.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/applications/office/kpilot/kpilot.spec')
-rw-r--r--redhat/applications/office/kpilot/kpilot.spec19
1 files changed, 15 insertions, 4 deletions
diff --git a/redhat/applications/office/kpilot/kpilot.spec b/redhat/applications/office/kpilot/kpilot.spec
index dd4c68ad5..828963b48 100644
--- a/redhat/applications/office/kpilot/kpilot.spec
+++ b/redhat/applications/office/kpilot/kpilot.spec
@@ -18,7 +18,7 @@
# TDE variables
%define tde_epoch 2
%if "%{?tde_version}" == ""
-%define tde_version 14.1.0
+%define tde_version 14.1.2
%endif
%define tde_pkg kpilot
%define tde_prefix /opt/trinity
@@ -69,16 +69,28 @@ BuildRequires: pkgconfig
BuildRequires: fdupes
# ACL support
+%if 0%{?mdkver}
+BuildRequires: %{_lib}acl-devel
+%else
BuildRequires: libacl-devel
+%endif
# ICAL support
+%if 0%{?mdkversion} || 0%{?mgaversion}
+BuildRequires: %{_lib}ical-devel
+%else
BuildRequires: libical-devel
+%endif
# IDN support
BuildRequires: libidn-devel
# OPENSSL support
+%if 0%{?mdkver}
+BuildRequires: %{_lib}openssl-devel
+%else
BuildRequires: openssl-devel
+%endif
# SUSE desktop files utility
%if 0%{?suse_version}
@@ -130,7 +142,7 @@ unset QTDIR QTINC QTLIB
export PATH="%{tde_bindir}:${PATH}"
export PKG_CONFIG_PATH="%{tde_libdir}/pkgconfig"
-if ! rpm -E %%cmake|grep -q "cd build"; then
+if ! rpm -E %%cmake|grep -e 'cd build\|cd ${CMAKE_BUILD_DIR:-build}'; then
%__mkdir_p build
cd build
fi
@@ -143,7 +155,6 @@ fi
-DCMAKE_SKIP_INSTALL_RPATH=OFF \
-DCMAKE_INSTALL_RPATH="%{tde_libdir}" \
-DCMAKE_VERBOSE_MAKEFILE=ON \
- -DWITH_GCC_VISIBILITY=OFF \
\
-DCMAKE_INSTALL_PREFIX="%{tde_prefix}" \
-DSHARE_INSTALL_PREFIX="%{tde_datadir}" \
@@ -169,7 +180,7 @@ export PATH="%{tde_bindir}:${PATH}"
# Unwanted files
%__rm -f %{?buildroot}%{tde_libdir}/libkpilot.so
-%__rm -fr %{?buildroot}%{tde_tdeincludedir}/kpilot/ %{?buildroot}%{_includedir}/kpilot/
+%__rm -fr %{?buildroot}%{tde_tdeincludedir}/kpilot/ %{?buildroot}%{tde_includedir}/kpilot/ %{?buildroot}%{_includedir}/kpilot/
# Updates applications categories for openSUSE
%if 0%{?suse_version}