summaryrefslogtreecommitdiffstats
path: root/redhat/applications/rosegarden/rosegarden-14.0.0.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/applications/rosegarden/rosegarden-14.0.0.spec')
-rw-r--r--redhat/applications/rosegarden/rosegarden-14.0.0.spec108
1 files changed, 73 insertions, 35 deletions
diff --git a/redhat/applications/rosegarden/rosegarden-14.0.0.spec b/redhat/applications/rosegarden/rosegarden-14.0.0.spec
index 2eaaeebfe..6e81f99b9 100644
--- a/redhat/applications/rosegarden/rosegarden-14.0.0.spec
+++ b/redhat/applications/rosegarden/rosegarden-14.0.0.spec
@@ -1,56 +1,79 @@
-# Default version for this component
-%define tde_pkg rosegarden
+#
+# spec file for package rosegarden (version R14.0.0)
+#
+# Copyright (c) 2014 Trinity Desktop Environment
+#
+# All modifications and additions to the file contributed by third parties
+# remain the property of their copyright owners, unless otherwise agreed
+# upon. The license for this file, and modifications and additions to the
+# file, is the same license as for the pristine package itself (unless the
+# license for the pristine package is not an Open Source License, in which
+# case the license is the MIT License). An "Open Source License" is a
+# license that conforms to the Open Source Definition (Version 1.9)
+# published by the Open Source Initiative.
+#
+# Please submit bugfixes or comments via http://www.trinitydesktop.org/
+#
+
+# TDE variables
+%define tde_epoch 2
%define tde_version 14.0.0
-
-# Required for Mageia 2: removes the ldflag '--no-undefined'
-%define _disable_ld_no_undefined 1
-
-# If TDE is built in a specific prefix (e.g. /opt/trinity), the release will be suffixed with ".opt".
-%if "%{?tde_prefix}" != "/usr"
-%define _variant .opt
-%endif
-
-# TDE specific building variables
+%define tde_pkg rosegarden
+%define tde_prefix /opt/trinity
%define tde_bindir %{tde_prefix}/bin
%define tde_datadir %{tde_prefix}/share
%define tde_docdir %{tde_datadir}/doc
%define tde_includedir %{tde_prefix}/include
%define tde_libdir %{tde_prefix}/%{_lib}
%define tde_mandir %{tde_datadir}/man
-%define tde_appdir %{tde_datadir}/applications
-
-%define tde_tdeappdir %{tde_appdir}/tde
+%define tde_tdeappdir %{tde_datadir}/applications/tde
%define tde_tdedocdir %{tde_docdir}/tde
%define tde_tdeincludedir %{tde_includedir}/tde
%define tde_tdelibdir %{tde_libdir}/trinity
-%define _docdir %{tde_tdedocdir}
-
-Name: trinity-%{tde_pkg}
-Summary: music editor and MIDI/audio sequencer [Trinity]
-Version: 1.7.0
-Release: %{?!preversion:7}%{?preversion:6_%{preversion}}%{?dist}%{?_variant}
+Name: trinity-%{tde_pkg}
+Epoch: %{tde_epoch}
+Version: 1.7.0
+Release: %{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}%{?_variant}
+Summary: Music editor and MIDI/audio sequencer [Trinity]
+Group: Applications/Multimedia
+URL: http://www.rosegardenmusic.com/
-License: GPLv2+
-Group: Applications/Multimedia
+%if 0%{?suse_version}
+License: GPL-2.0+
+%else
+License: GPLv2+
+%endif
-Vendor: Trinity Project
-Packager: Francois Andriot <francois.andriot@free.fr>
-URL: http://www.rosegardenmusic.com/
+#Vendor: Trinity Desktop
+#Packager: Francois Andriot <francois.andriot@free.fr>
-Prefix: %{tde_prefix}
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+Prefix: %{tde_prefix}
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Source0: %{name}-%{tde_version}%{?preversion:~%{preversion}}.tar.gz
-BuildRequires: trinity-tqtinterface-devel >= %{tde_version}
-BuildRequires: trinity-arts-devel >= 1:1.5.10
BuildRequires: trinity-tdelibs-devel >= %{tde_version}
BuildRequires: trinity-tdebase-devel >= %{tde_version}
BuildRequires: desktop-file-utils
-
BuildRequires: gettext
+
+BuildRequires: cmake libtool
+BuildRequires: gcc-c++
+BuildRequires: pkgconfig
+BuildRequires: fdupes
+
+# SUSE desktop files utility
+%if 0%{?suse_version}
+BuildRequires: update-desktop-files
+%endif
+
+%if 0%{?opensuse_bs} && 0%{?suse_version}
+# for xdg-menu script
+BuildRequires: brp-check-trinity
+%endif
+
BuildRequires: fftw-devel
BuildRequires: liblo-devel
BuildRequires: fontconfig-devel
@@ -78,6 +101,16 @@ BuildRequires: jack-audio-connection-kit-devel
BuildRequires: lirc-devel
%endif
+# IDN support
+BuildRequires: libidn-devel
+
+# GAMIN support
+# Not on openSUSE.
+%if 0%{?rhel} || 0%{?fedora} || 0%{?mgaversion} || 0%{?mdkversion}
+%define with_gamin 1
+BuildRequires: gamin-devel
+%endif
+
Requires: lilypond
Requires: perl-XML-Twig
@@ -94,6 +127,7 @@ Requires: libsndfile-utils
Requires: %{name}-data == %{version}-%{release}
+
%description
Rosegarden is a TDE application which provides a mixed Audio/MIDI
sequencer (for playback and recording), a multi-track editor, music
@@ -114,10 +148,14 @@ lilypond and Csound files export, etc.
This package provides the data files necessary for running Rosegarden
-%if 0%{?suse_version} || 0%{?pclinuxos}
+##########
+
+%if 0%{?pclinuxos} || 0%{?suse_version} && 0%{?opensuse_bs} == 0
%debug_package
%endif
+##########
+
%prep
%setup -q -n %{name}-%{tde_version}%{?preversion:~%{preversion}}
@@ -177,14 +215,14 @@ export PATH="%{tde_bindir}:${PATH}"
%post
-update-desktop-database %{tde_appdir} > /dev/null
+update-desktop-database %{tde_tdeappdir} > /dev/null
for f in hicolor locolor; do
touch --no-create %{tde_datadir}/icons/${f} || :
gtk-update-icon-cache --quiet %{tde_datadir}/icons/${f} || :
done
%postun
-update-desktop-database %{tde_appdir} > /dev/null
+update-desktop-database %{tde_tdeappdir} > /dev/null
for f in hicolor locolor; do
touch --no-create %{tde_datadir}/icons/${f} || :
gtk-update-icon-cache --quiet %{tde_datadir}/icons/${f} || :
@@ -217,5 +255,5 @@ done
%changelog
-* Mon Jul 29 2013 Francois Andriot <francois.andriot@free.fr> - 1.7.0-7
+* Mon Jul 29 2013 Francois Andriot <francois.andriot@free.fr> - 2:1.7.0-1
- Initial release for TDE 14.0.0