summaryrefslogtreecommitdiffstats
path: root/redhat/applications/system/kbfx/kbfx.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/applications/system/kbfx/kbfx.spec')
-rw-r--r--redhat/applications/system/kbfx/kbfx.spec10
1 files changed, 9 insertions, 1 deletions
diff --git a/redhat/applications/system/kbfx/kbfx.spec b/redhat/applications/system/kbfx/kbfx.spec
index 6f6793490..849735a3c 100644
--- a/redhat/applications/system/kbfx/kbfx.spec
+++ b/redhat/applications/system/kbfx/kbfx.spec
@@ -91,10 +91,18 @@ BuildRequires: gamin-devel
BuildRequires: pcre-devel
# ACL support
+%if 0%{?mdkver}
+BuildRequires: %{_lib}acl-devel
+%else
BuildRequires: libacl-devel
+%endif
# OPENSSL support
+%if 0%{?mdkver}
+BuildRequires: %{_lib}openssl-devel
+%else
BuildRequires: openssl-devel
+%endif
%description
@@ -137,7 +145,7 @@ if [ -d "/usr/X11R6" ]; then
export RPM_OPT_FLAGS="${RPM_OPT_FLAGS} -I/usr/X11R6/include -L/usr/X11R6/%{_lib}"
fi
-if ! rpm -E %%cmake|grep -q "cd build"; then
+if ! rpm -E %%cmake|grep -e 'cd build\|cd ${CMAKE_BUILD_DIR:-build}'; then
%__mkdir_p build
cd build
fi