summaryrefslogtreecommitdiffstats
path: root/redhat/applications/tdeio/tdeio-sword/tdeio-sword.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/applications/tdeio/tdeio-sword/tdeio-sword.spec')
-rw-r--r--redhat/applications/tdeio/tdeio-sword/tdeio-sword.spec12
1 files changed, 10 insertions, 2 deletions
diff --git a/redhat/applications/tdeio/tdeio-sword/tdeio-sword.spec b/redhat/applications/tdeio/tdeio-sword/tdeio-sword.spec
index 8a3804e89..5881bdfbe 100644
--- a/redhat/applications/tdeio/tdeio-sword/tdeio-sword.spec
+++ b/redhat/applications/tdeio/tdeio-sword/tdeio-sword.spec
@@ -23,7 +23,7 @@
# TDE variables
%define tde_epoch 2
%if "%{?tde_version}" == ""
-%define tde_version 14.1.0
+%define tde_version 14.1.2
%endif
%define tde_pkg tdeio-sword
%define tde_prefix /opt/trinity
@@ -72,13 +72,21 @@ BuildRequires: pkgconfig
BuildRequires: fdupes
# ACL support
+%if 0%{?mdkver}
+BuildRequires: %{_lib}acl-devel
+%else
BuildRequires: libacl-devel
+%endif
# IDN support
BuildRequires: libidn-devel
# OPENSSL support
+%if 0%{?mdkver}
+BuildRequires: %{_lib}openssl-devel
+%else
BuildRequires: openssl-devel
+%endif
# SUSE desktop files utility
%if 0%{?suse_version}
@@ -121,7 +129,7 @@ unset QTDIR QTINC QTLIB
export PATH="%{tde_bindir}:${PATH}"
export PKG_CONFIG_PATH="%{tde_libdir}/pkgconfig"
-if ! rpm -E %%cmake|grep -q "cd build"; then
+if ! rpm -E %%cmake|grep -e 'cd build\|cd ${CMAKE_BUILD_DIR:-build}'; then
%__mkdir_p build
cd build
fi