summaryrefslogtreecommitdiffstats
path: root/redhat/core/tdevelop/tdevelop.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/core/tdevelop/tdevelop.spec')
-rw-r--r--redhat/core/tdevelop/tdevelop.spec16
1 files changed, 14 insertions, 2 deletions
diff --git a/redhat/core/tdevelop/tdevelop.spec b/redhat/core/tdevelop/tdevelop.spec
index bb060e8af..3f718693b 100644
--- a/redhat/core/tdevelop/tdevelop.spec
+++ b/redhat/core/tdevelop/tdevelop.spec
@@ -137,8 +137,12 @@ BuildRequires: neon-devel
# OPENLDAP support
%if 0%{?rhel} >= 6 || 0%{?fedora} || 0%{?mdkversion} || 0%{?mgaversion}
+%if 0%{?mdkver}
+BuildRequires: lib64ldap-devel
+%else
BuildRequires: openldap-devel
%endif
+%endif
%if 0%{?suse_version}
BuildRequires: openldap2-devel
%endif
@@ -148,11 +152,20 @@ BuildRequires: openldap24-libs-devel
# LIBACL support
%if 0%{?suse_version} || 0%{?rhel} >= 5 || 0%{?fedora} || 0%{?mgaversion} || 0%{?mdkversion}
+# ACL support
+%if 0%{?mdkver}
+BuildRequires: %{_lib}acl-devel
+%else
BuildRequires: libacl-devel
%endif
+%endif
# OPENSSL support
+%if 0%{?mdkver}
+BuildRequires: %{_lib}openssl-devel
+%else
BuildRequires: openssl-devel
+%endif
# PYTHON support
%global python python3
@@ -517,7 +530,6 @@ individual needs.
%{tde_libdir}/libkinterfacedesigner.so.0.0.0
%{tde_tdelibdir}/libkdevvisualboyadvance.la
%{tde_tdelibdir}/libkdevvisualboyadvance.so
-%{tde_datadir}/apps/kdevdesignerpart/pics/
%{tde_datadir}/apps/kdevvisualboyadvance/
%{tde_tdedocdir}/HTML/en/tde_app_devel/
%{tde_datadir}/mimelnk/text/x-fortran.desktop
@@ -622,7 +634,7 @@ if [ -d "/usr/include/openldap24" ]; then
fi
-if ! rpm -E %%cmake|grep -q "cd build"; then
+if ! rpm -E %%cmake|grep -e 'cd build\|cd ${CMAKE_BUILD_DIR:-build}'; then
%__mkdir_p build
cd build
fi