summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/dependencies/tqtinterface/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/_base/dependencies/tqtinterface/debian/rules')
-rwxr-xr-xubuntu/_base/dependencies/tqtinterface/debian/rules28
1 files changed, 28 insertions, 0 deletions
diff --git a/ubuntu/_base/dependencies/tqtinterface/debian/rules b/ubuntu/_base/dependencies/tqtinterface/debian/rules
new file mode 100755
index 000000000..7f0eea47b
--- /dev/null
+++ b/ubuntu/_base/dependencies/tqtinterface/debian/rules
@@ -0,0 +1,28 @@
+#! /usr/bin/make -f
+# see debian/rules file for kdesvn for cmake examples
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
+#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+include /usr/share/cdbs/1/rules/utils.mk
+
+DEB_KDE_APIDOX := yes
+
+version=Debian Package $(DEB_VERSION)
+DEB_OPT_FLAG += -DDEBIAN_VERSION=$(DEB_VERSION)
+
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DBUILD_ALL="ON" \
+ -DWITH_QT3="ON"
+
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
+# Honour "parallel=N" option of DEB_BUILD_OPTIONS. Comment out to
+# never build in parallel, regardless of DEB_BUILD_OPTIONS.
+DEB_BUILD_PARALLEL = true
+
+DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)