summaryrefslogtreecommitdiffstats
path: root/client/Makefile.am
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2016-04-05 02:46:02 +0200
committerSlávek Banko <slavek.banko@axis.cz>2016-04-05 02:46:02 +0200
commit0fa8770a5566743737ef2812d1f4e6c04d968cda (patch)
tree2b21a699d9c5a5b4af649f3a7046bb9ae4cb9ad7 /client/Makefile.am
downloadtde-style-domino-0fa8770a5566743737ef2812d1f4e6c04d968cda.tar.gz
tde-style-domino-0fa8770a5566743737ef2812d1f4e6c04d968cda.zip
Initial import of kde-style-domino 0.4
Diffstat (limited to 'client/Makefile.am')
-rw-r--r--client/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/client/Makefile.am b/client/Makefile.am
new file mode 100644
index 0000000..3ee503b
--- /dev/null
+++ b/client/Makefile.am
@@ -0,0 +1,16 @@
+
+INCLUDES = $(all_includes) -I$(kde_includes)/kwin
+
+SUBDIRS = . config
+
+kde_module_LTLIBRARIES = kwin3_domino.la
+
+kwin3_domino_la_SOURCES = dominoclient.cpp
+kwin3_domino_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN) -module -L/usr/X11R6/lib
+kwin3_domino_la_LIBADD = $(LIB_KDECORE) $(kde_libraries)/libkdecorations.la -lXext -lX11 $(LIB_QT)
+
+METASOURCES = AUTO
+noinst_HEADERS = dominoclient.h
+
+lnkdir = $(kde_datadir)/kwin
+lnk_DATA = domino.desktop