summaryrefslogtreecommitdiffstats
path: root/client/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'client/CMakeLists.txt')
-rw-r--r--client/CMakeLists.txt42
1 files changed, 42 insertions, 0 deletions
diff --git a/client/CMakeLists.txt b/client/CMakeLists.txt
new file mode 100644
index 0000000..138918b
--- /dev/null
+++ b/client/CMakeLists.txt
@@ -0,0 +1,42 @@
+tde_import( twin )
+
+add_subdirectory( config )
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${XCB_SHAPE_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIBRARY_DIRS}
+ ${XCB_SHAPE_LIBRARY_DIRS}
+)
+
+
+##### twin3_domino (kpart)
+
+tde_add_kpart( twin3_domino AUTOMOC
+
+ SOURCES
+ dominoclient.cpp
+ LINK
+ tdecore-shared
+ tdecorations-shared
+ ${X11_LIBRARIES}
+ ${XCB_SHAPE_LIBRARIES}
+
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)
+
+
+##### other data
+
+install(
+ FILES domino.desktop
+ DESTINATION ${DATA_INSTALL_DIR}/twin
+)