summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-07-12 12:56:37 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-07-12 12:56:55 +0200
commit802f34e6ab13d295f7035599ce2478a90c704c9b (patch)
treedc197df411b7adc2539525a730013197ebd435b0 /CMakeLists.txt
parentc2d0b544d4623d7e92d0a21a42ae390cf80e6dee (diff)
downloadtde-style-ia-ora-802f34e6ab13d295f7035599ce2478a90c704c9b.tar.gz
tde-style-ia-ora-802f34e6ab13d295f7035599ce2478a90c704c9b.zip
Add CMakeL10n rules.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit ef1942f65a25011fc41613900b0c6a91ae2f4763)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 21a75bc..3a9fe20 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -45,6 +45,12 @@ option( WITH_ALL_OPTIONS "Enable all optional support" OFF
option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
+##### user requested modules
+
+option( BUILD_ALL "Build all" ON )
+option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
+
+
##### configure checks
include( ConfigureChecks.cmake )
@@ -64,6 +70,11 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
add_subdirectory( src )
+##### other data ################################
+
+tde_conditional_add_project_translations( BUILD_TRANSLATIONS )
+
+
##### write configure files
configure_file( config.h.cmake config.h @ONLY )