summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <gregory-tde@laposte.net>2020-09-30 07:56:33 +0200
committerMichele Calgaro <michele.calgaro@yahoo.it>2020-10-03 23:46:53 +0900
commit82e80513f7851d3c01cd26fc1fb1e1256915cc56 (patch)
tree3c3a4a67c13262254a166aaa67f4e95f8af46ec1 /CMakeLists.txt
parent18f8b5c10c5d2bf173b29127867a1c04b67e6cf7 (diff)
downloadtde-style-lipstik-82e80513f7851d3c01cd26fc1fb1e1256915cc56.tar.gz
tde-style-lipstik-82e80513f7851d3c01cd26fc1fb1e1256915cc56.zip
Drop automake build support.
Add basic cmake build instructions. Deleted empty file NEWS. Deleted spec file (rpm) lipstik.spec. Rework of the README file. Some cosmetics. Signed-off-by: gregory guy <gregory-tde@laposte.net> (cherry picked from commit 07a6d98c1b4a852cfaca3ac02b388351909d7b9c)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1bf3d5c..415c7ca 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,13 +41,13 @@ tde_setup_paths( )
##### optional stuff
-option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
+option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
##### user requested modules
-option( BUILD_ALL "Build all" ON )
+option( BUILD_ALL "Build all" ON )
option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )