summaryrefslogtreecommitdiffstats
path: root/style/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2024-03-22 20:52:44 +0900
committerMavridis Philippe <mavridisf@gmail.com>2024-03-24 23:17:01 +0200
commitfd62635a2792b5cbbbae1c5288992af0054332ee (patch)
tree142ee8d27f069a78e367f1eaa837d6e4c2c600ea /style/CMakeLists.txt
parent57f8e4dbf7dc6cce58dfc11b5aab03e86b7cbdc7 (diff)
downloadtde-style-polyester-fd62635a2792b5cbbbae1c5288992af0054332ee.tar.gz
tde-style-polyester-fd62635a2792b5cbbbae1c5288992af0054332ee.zip
Use centralized cmake version. Align cmake files to usual TDE style
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'style/CMakeLists.txt')
-rw-r--r--style/CMakeLists.txt11
1 files changed, 8 insertions, 3 deletions
diff --git a/style/CMakeLists.txt b/style/CMakeLists.txt
index 8087699..e1a076b 100644
--- a/style/CMakeLists.txt
+++ b/style/CMakeLists.txt
@@ -19,9 +19,10 @@ link_directories(
${TDE_LIBRARY_DIRS}
)
+
### polyester (kpart) ##########################################################
-tde_add_kpart(polyester
- AUTOMOC
+
+tde_add_kpart( polyester AUTOMOC
SOURCES
polyester.cpp
@@ -33,11 +34,15 @@ tde_add_kpart(polyester
DESTINATION ${PLUGIN_INSTALL_DIR}/plugins/styles
)
+
### configuration module #######################################################
+
add_subdirectory(config)
+
### other data #################################################################
+
install(
FILES polyester.themerc
DESTINATION ${DATA_INSTALL_DIR}/tdestyle/themes
-) \ No newline at end of file
+)