summaryrefslogtreecommitdiffstats
path: root/kate/xmltools/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit84da08d7b7fcda12c85caeb5a10b4903770a6f69 (patch)
tree2a6aea76f2dfffb4cc04bb907c4725af94f70e72 /kate/xmltools/Makefile.am
downloadtdeaddons-84da08d7b7fcda12c85caeb5a10b4903770a6f69.tar.gz
tdeaddons-84da08d7b7fcda12c85caeb5a10b4903770a6f69.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdeaddons@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kate/xmltools/Makefile.am')
-rw-r--r--kate/xmltools/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/kate/xmltools/Makefile.am b/kate/xmltools/Makefile.am
new file mode 100644
index 0000000..64a9b60
--- /dev/null
+++ b/kate/xmltools/Makefile.am
@@ -0,0 +1,30 @@
+INCLUDES = $(all_includes)
+METASOURCES = AUTO
+
+# Install this plugin in the KDE modules directory
+kde_module_LTLIBRARIES = katexmltoolsplugin.la
+
+# This is all standard. Remove the LIB_KHTML reference if you are not
+# using the KHTML Part
+katexmltoolsplugin_la_SOURCES = pseudo_dtd.cpp plugin_katexmltools.cpp
+katexmltoolsplugin_la_LIBADD = -lkateinterfaces
+katexmltoolsplugin_la_LDFLAGS = -module $(KDE_PLUGIN) $(all_libraries)
+
+# Install the .rc file in the Part's directory (in this case, the part
+# is KHTMLPart)
+pluginsdir = $(kde_datadir)/kate/plugins/katexmltools
+plugins_DATA = ui.rc
+
+xmldir = $(kde_datadir)/katexmltools
+xml_DATA = html4-loose.dtd.xml html4-strict.dtd.xml kde-docbook.dtd.xml \
+ simplify_dtd.xsl xhtml1-frameset.dtd.xml xhtml1-strict.dtd.xml \
+ xhtml1-transitional.dtd.xml xslt-1.0.dtd.xml \
+ testcases.xml language.dtd.xml kpartgui.dtd.xml kcfg.dtd.xml
+
+#deskdir=$(kde_datadir)/kate/plugins
+#desk_DATA=katexmltools.desktop
+
+kde_services_DATA = katexmltools.desktop
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/katexmltools.pot