summaryrefslogtreecommitdiffstats
path: root/kfile-plugins/mhtml/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit84da08d7b7fcda12c85caeb5a10b4903770a6f69 (patch)
tree2a6aea76f2dfffb4cc04bb907c4725af94f70e72 /kfile-plugins/mhtml/Makefile.am
downloadtdeaddons-84da08d7b7fcda12c85caeb5a10b4903770a6f69.tar.gz
tdeaddons-84da08d7b7fcda12c85caeb5a10b4903770a6f69.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdeaddons@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kfile-plugins/mhtml/Makefile.am')
-rw-r--r--kfile-plugins/mhtml/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/kfile-plugins/mhtml/Makefile.am b/kfile-plugins/mhtml/Makefile.am
new file mode 100644
index 0000000..326820d
--- /dev/null
+++ b/kfile-plugins/mhtml/Makefile.am
@@ -0,0 +1,21 @@
+## Makefile.am for folder file meta info plugin
+
+INCLUDES = $(all_includes)
+
+# these are the headers for your project
+noinst_HEADERS = kfile_mhtml.h
+
+kde_module_LTLIBRARIES = kfile_mhtml.la
+
+kfile_mhtml_la_SOURCES = kfile_mhtml.cpp
+kfile_mhtml_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+kfile_mhtml_la_LIBADD = $(LIB_KIO)
+
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO
+
+services_DATA = kfile_mhtml.desktop
+servicesdir = $(kde_servicesdir)
+
+messages:
+ $(XGETTEXT) *.cpp -o $(podir)/kfile_mhtml.pot