summaryrefslogtreecommitdiffstats
path: root/konq-plugins/autorefresh/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit84da08d7b7fcda12c85caeb5a10b4903770a6f69 (patch)
tree2a6aea76f2dfffb4cc04bb907c4725af94f70e72 /konq-plugins/autorefresh/Makefile.am
downloadtdeaddons-84da08d7b7fcda12c85caeb5a10b4903770a6f69.tar.gz
tdeaddons-84da08d7b7fcda12c85caeb5a10b4903770a6f69.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdeaddons@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'konq-plugins/autorefresh/Makefile.am')
-rw-r--r--konq-plugins/autorefresh/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/konq-plugins/autorefresh/Makefile.am b/konq-plugins/autorefresh/Makefile.am
new file mode 100644
index 0000000..f97432b
--- /dev/null
+++ b/konq-plugins/autorefresh/Makefile.am
@@ -0,0 +1,21 @@
+kde_module_LTLIBRARIES = libautorefresh.la
+
+INCLUDES = $(all_includes)
+
+libautorefresh_la_METASOURCES = AUTO
+libautorefresh_la_SOURCES = autorefresh.cpp
+libautorefresh_la_LIBADD = $(LIB_KHTML)
+
+libautorefresh_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+
+KDE_ICON = autorefresh
+
+autorefreshdir = $(kde_datadir)/khtml/kpartplugins
+autorefresh_DATA = autorefresh.rc autorefresh.desktop
+
+messages: rc.cpp
+ LIST=`find . -name \*.h -o -name \*.hh -o -name \*.H -o -name \*.hxx -o -name \*.hpp -o -name \*.cpp -o -name \*.cc -o -name \*.cxx -o -name \*.ecpp -o -name \*.C`; \
+ if test -n "$$LIST"; then \
+ $(XGETTEXT) $$LIST -o $(podir)/autorefresh.pot; \
+ fi
+