summaryrefslogtreecommitdiffstats
path: root/konq-plugins/sidebar/delicious/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit84da08d7b7fcda12c85caeb5a10b4903770a6f69 (patch)
tree2a6aea76f2dfffb4cc04bb907c4725af94f70e72 /konq-plugins/sidebar/delicious/Makefile.am
downloadtdeaddons-84da08d7b7fcda12c85caeb5a10b4903770a6f69.tar.gz
tdeaddons-84da08d7b7fcda12c85caeb5a10b4903770a6f69.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdeaddons@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'konq-plugins/sidebar/delicious/Makefile.am')
-rw-r--r--konq-plugins/sidebar/delicious/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/konq-plugins/sidebar/delicious/Makefile.am b/konq-plugins/sidebar/delicious/Makefile.am
new file mode 100644
index 0000000..cb8eb48
--- /dev/null
+++ b/konq-plugins/sidebar/delicious/Makefile.am
@@ -0,0 +1,22 @@
+SUBDIRS = . pics
+
+METASOURCES = AUTO
+INCLUDES = -I$(kde_includes)/kio $(all_includes)
+
+################################
+# these are the headers for your project
+noinst_HEADERS = plugin.h mainWidget.h tagListItem.h bookmarkListItem.h
+
+kde_module_LTLIBRARIES = konqsidebar_delicious.la
+
+# the Part's source, library search path, and link libraries
+konqsidebar_delicious_la_SOURCES = plugin.cpp widget.ui mainWidget.cpp plugin.skel tagListItem.cpp \
+ bookmarkListItem.cpp
+konqsidebar_delicious_la_LDFLAGS = -module $(KDE_PLUGIN) $(all_libraries)
+konqsidebar_delicious_la_LIBADD = $(LIB_KPARTS) $(LIB_KIO) -lkonqsidebarplugin
+
+globaladddir = $(kde_datadir)/konqsidebartng/add
+globaladd_DATA = delicious_add.desktop
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/konqsidebar_delicious.pot