summaryrefslogtreecommitdiffstats
path: root/konq-plugins/sidebar/mediaplayer/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit84da08d7b7fcda12c85caeb5a10b4903770a6f69 (patch)
tree2a6aea76f2dfffb4cc04bb907c4725af94f70e72 /konq-plugins/sidebar/mediaplayer/Makefile.am
downloadtdeaddons-84da08d7b7fcda12c85caeb5a10b4903770a6f69.tar.gz
tdeaddons-84da08d7b7fcda12c85caeb5a10b4903770a6f69.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdeaddons@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'konq-plugins/sidebar/mediaplayer/Makefile.am')
-rw-r--r--konq-plugins/sidebar/mediaplayer/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/konq-plugins/sidebar/mediaplayer/Makefile.am b/konq-plugins/sidebar/mediaplayer/Makefile.am
new file mode 100644
index 0000000..12ba913
--- /dev/null
+++ b/konq-plugins/sidebar/mediaplayer/Makefile.am
@@ -0,0 +1,33 @@
+# this has all of the subdirectories that make will recurse into. if
+# there are none, comment this out
+SUBDIRS = . pics
+
+# set the include path for X, qt and KDE
+INCLUDES = -I$(kde_includes)/kio -I$(kde_includes)/arts $(all_includes)
+
+# these are the headers for your project
+noinst_HEADERS =
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO
+
+kde_module_LTLIBRARIES = konqsidebar_mediaplayer.la
+
+# the Part's source, library search path, and link libraries
+konqsidebar_mediaplayer_la_SOURCES = mediawidget_skel.ui engine.cpp player.cpp mediawidget.cpp mediaplayer.cpp controls.cpp
+konqsidebar_mediaplayer_la_LDFLAGS = -module $(KDE_PLUGIN) $(all_libraries)
+konqsidebar_mediaplayer_la_LIBADD = $(LIB_KPARTS) $(LIB_KFILE) -lkonqsidebarplugin -lqtmcop -lkmedia2_idl -lsoundserver_idl -lartskde
+
+globaladddir = $(kde_datadir)/konqsidebartng/add
+globaladd_DATA = mplayer_add.desktop
+
+appsdir = $(kde_appsdir)/.hidden
+apps_DATA = mediaplayerplugin.desktop
+
+mediawidget_skel.ui: mediawidget_skel_designer.ui
+ perl -p -e "s/QSlider/L33tSlider/" mediawidget_skel_designer.ui >mediawidget_skel.ui
+
+extendedclean:
+ rm mediawidget_skel.*
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp *.h -o $(podir)/konqsidebar_mediaplayer.pot