summaryrefslogtreecommitdiffstats
path: root/konq-plugins/uachanger/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit84da08d7b7fcda12c85caeb5a10b4903770a6f69 (patch)
tree2a6aea76f2dfffb4cc04bb907c4725af94f70e72 /konq-plugins/uachanger/Makefile.am
downloadtdeaddons-84da08d7b7fcda12c85caeb5a10b4903770a6f69.tar.gz
tdeaddons-84da08d7b7fcda12c85caeb5a10b4903770a6f69.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdeaddons@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'konq-plugins/uachanger/Makefile.am')
-rw-r--r--konq-plugins/uachanger/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/konq-plugins/uachanger/Makefile.am b/konq-plugins/uachanger/Makefile.am
new file mode 100644
index 0000000..80e2c2b
--- /dev/null
+++ b/konq-plugins/uachanger/Makefile.am
@@ -0,0 +1,17 @@
+kde_module_LTLIBRARIES = libuachangerplugin.la
+
+AM_CPPFLAGS = $(all_includes)
+METASOURCES = AUTO
+
+libuachangerplugin_la_SOURCES = uachangerplugin.cpp
+libuachangerplugin_la_LIBADD = $(LIB_KPARTS) $(LIB_KHTML)
+libuachangerplugin_la_LDFLAGS = -module $(KDE_PLUGIN) $(all_libraries)
+
+pluginsdir = $(kde_datadir)/khtml/kpartplugins
+plugins_DATA = uachangerplugin.rc uachangerplugin.desktop
+
+appsdir = $(kde_appsdir)/.hidden
+apps_DATA = uachangerplugin.desktop
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp *.h -o $(podir)/uachangerplugin.pot