summaryrefslogtreecommitdiffstats
path: root/noatun-plugins/tippercanoe/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit84da08d7b7fcda12c85caeb5a10b4903770a6f69 (patch)
tree2a6aea76f2dfffb4cc04bb907c4725af94f70e72 /noatun-plugins/tippercanoe/Makefile.am
downloadtdeaddons-84da08d7b7fcda12c85caeb5a10b4903770a6f69.tar.gz
tdeaddons-84da08d7b7fcda12c85caeb5a10b4903770a6f69.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdeaddons@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'noatun-plugins/tippercanoe/Makefile.am')
-rw-r--r--noatun-plugins/tippercanoe/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/noatun-plugins/tippercanoe/Makefile.am b/noatun-plugins/tippercanoe/Makefile.am
new file mode 100644
index 0000000..b557d10
--- /dev/null
+++ b/noatun-plugins/tippercanoe/Makefile.am
@@ -0,0 +1,21 @@
+INCLUDES= $(all_includes) $(SDL_CFLAGS)
+
+METASOURCES = AUTO
+
+kde_module_LTLIBRARIES = noatuntippecanoe.la
+
+noatuntippecanoe_la_SOURCES = synaescope.cpp
+noatuntippecanoe_la_LDFLAGS = $(all_libraries) -module -avoid-version -no-undefined
+noatuntippecanoe_la_LIBADD = $(LIB_KFILE) -lnoatun -lm
+
+bin_PROGRAMS = noatuntippecanoe.bin
+
+noatuntippecanoe_bin_SOURCES = core.cpp main.cpp ui.cpp sdlwrap.cpp
+noatuntippecanoe_bin_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+noatuntippecanoe_bin_LDADD = $(LIB_KDEUI) -lm $(SDL_LIBS)
+
+noatun_DATA = tippecanoe.plugin
+noatundir = $(kde_datadir)/noatun
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp *.h -o $(podir)/tippecanoe.pot