summaryrefslogtreecommitdiffstats
path: root/atlantikdesigner/designer/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'atlantikdesigner/designer/CMakeLists.txt')
-rw-r--r--atlantikdesigner/designer/CMakeLists.txt34
1 files changed, 34 insertions, 0 deletions
diff --git a/atlantikdesigner/designer/CMakeLists.txt b/atlantikdesigner/designer/CMakeLists.txt
new file mode 100644
index 0000000..5cf5f67
--- /dev/null
+++ b/atlantikdesigner/designer/CMakeLists.txt
@@ -0,0 +1,34 @@
+#################################################
+#
+# (C) 2013 Slávek Banko
+# slavek (DOT) banko (AT) axis.cz
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}/tde
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TDE_LIB_DIR}
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### atlantikdesigner (executable) #########################
+
+tde_add_executable( atlantikdesigner AUTOMOC
+ SOURCES boardinfo.cpp designer.cpp editor.cpp main.cpp group.cpp
+ LINK tdeio-shared atlantic atlantikui tdegames DCOP
+ DESTINATION ${BIN_INSTALL_DIR}
+)
+