summaryrefslogtreecommitdiffstats
path: root/kaddressbook-plugins/xxports/kworldclock/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kaddressbook-plugins/xxports/kworldclock/Makefile.am')
-rw-r--r--kaddressbook-plugins/xxports/kworldclock/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/kaddressbook-plugins/xxports/kworldclock/Makefile.am b/kaddressbook-plugins/xxports/kworldclock/Makefile.am
new file mode 100644
index 0000000..ee28aa6
--- /dev/null
+++ b/kaddressbook-plugins/xxports/kworldclock/Makefile.am
@@ -0,0 +1,17 @@
+INCLUDES = $(all_includes)
+
+kde_module_LTLIBRARIES = libkaddrbk_geo_xxport.la
+
+servicedir = $(kde_servicesdir)/kaddressbook
+service_DATA = geo_xxport.desktop
+
+libkaddrbk_geo_xxport_la_SOURCES = geo_xxport.cpp
+libkaddrbk_geo_xxport_la_LDFLAGS = -module $(KDE_PLUGIN) $(KDE_RPATH) $(all_libraries)
+libkaddrbk_geo_xxport_la_LIBADD = $(LIB_KDEUI) -lkabc -lkabinterfaces
+libkaddrbk_geo_xxport_la_METASOURCES = AUTO
+
+rc_DATA = geo_xxportui.rc
+rcdir = $(kde_datadir)/kaddressbook
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp *.h -o $(podir)/libkaddrbk_geo_xxport.pot