summaryrefslogtreecommitdiffstats
path: root/kate/filetemplates/plugin/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kate/filetemplates/plugin/Makefile.am')
-rw-r--r--kate/filetemplates/plugin/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/kate/filetemplates/plugin/Makefile.am b/kate/filetemplates/plugin/Makefile.am
new file mode 100644
index 0000000..7963916
--- /dev/null
+++ b/kate/filetemplates/plugin/Makefile.am
@@ -0,0 +1,25 @@
+INCLUDES = $(all_includes)
+METASOURCES = AUTO
+
+subdirs=src templates
+
+#KDE_ICON = filetemplates
+
+# Install this plugin in the KDE modules directory
+kde_module_LTLIBRARIES = katefiletemplates.la
+
+katefiletemplates_la_SOURCES = filetemplates.cpp
+katefiletemplates_la_LIBADD = -lkateinterfaces -lktexteditor $(LIB_KNEWSTUFF)
+katefiletemplates_la_LDFLAGS = -module $(KDE_PLUGIN) $(all_libraries)
+
+pluginsdir = $(kde_datadir)/kate/plugins/katefiletemplates
+plugins_DATA = ui.rc
+
+syntaxdir = $(kde_datadir)/katepart/syntax
+syntax_DATA = katetemplate.xml
+
+kde_services_DATA = katefiletemplates.desktop
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/katefiletemplates.pot
+