summaryrefslogtreecommitdiffstats
path: root/kate/helloworld/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kate/helloworld/Makefile.am')
-rw-r--r--kate/helloworld/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/kate/helloworld/Makefile.am b/kate/helloworld/Makefile.am
new file mode 100644
index 0000000..b3fca29
--- /dev/null
+++ b/kate/helloworld/Makefile.am
@@ -0,0 +1,18 @@
+INCLUDES = $(all_includes)
+METASOURCES = AUTO
+
+# Install this plugin in the KDE modules directory
+kde_module_LTLIBRARIES = katehelloworldplugin.la
+
+katehelloworldplugin_la_SOURCES = plugin_katehelloworld.cpp
+katehelloworldplugin_la_LIBADD = -lkateinterfaces
+katehelloworldplugin_la_LDFLAGS = -module $(KDE_PLUGIN) $(all_libraries)
+
+pluginsdir = $(kde_datadir)/kate/plugins/katehelloworld
+plugins_DATA = ui.rc
+
+kde_services_DATA = katehelloworld.desktop
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/katehelloworld.pot
+