summaryrefslogtreecommitdiffstats
path: root/kate/make/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kate/make/CMakeLists.txt')
-rw-r--r--kate/make/CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/kate/make/CMakeLists.txt b/kate/make/CMakeLists.txt
new file mode 100644
index 0000000..21f6bd9
--- /dev/null
+++ b/kate/make/CMakeLists.txt
@@ -0,0 +1,29 @@
+# This file is genereted by triniy-automake-cmake-convert script by Fat-Zer
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### katemakeplugin (kpart) ####################
+
+tde_add_kpart( katemakeplugin AUTOMOC
+ SOURCES plugin_katemake.cpp
+ LINK kateinterfaces-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)
+
+
+##### other data ################################
+
+install( FILES ui.rc
+ DESTINATION ${DATA_INSTALL_DIR}/kate/plugins/katemake
+)