summaryrefslogtreecommitdiffstats
path: root/konq-plugins/arkplugin/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'konq-plugins/arkplugin/Makefile.am')
-rw-r--r--konq-plugins/arkplugin/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/konq-plugins/arkplugin/Makefile.am b/konq-plugins/arkplugin/Makefile.am
new file mode 100644
index 0000000..0f6ec44
--- /dev/null
+++ b/konq-plugins/arkplugin/Makefile.am
@@ -0,0 +1,18 @@
+INCLUDES = $(all_includes)
+METASOURCES = AUTO
+
+# Install this plugin in the KDE modules directory
+kde_module_LTLIBRARIES = libarkplugin.la
+
+libarkplugin_la_SOURCES = arkplugin.cpp
+libarkplugin_la_LIBADD = -lkonq
+libarkplugin_la_LDFLAGS = -module $(KDE_PLUGIN) $(all_libraries)
+
+pluginsdir = $(kde_servicesdir)
+plugins_DATA = ark_plugin.desktop
+
+appsdir = $(kde_appsdir)/.hidden
+apps_DATA = arkplugin.desktop
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp *.h -o $(podir)/ark_plugin.pot