summaryrefslogtreecommitdiffstats
path: root/konq-plugins/fsview/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'konq-plugins/fsview/Makefile.am')
-rw-r--r--konq-plugins/fsview/Makefile.am51
1 files changed, 51 insertions, 0 deletions
diff --git a/konq-plugins/fsview/Makefile.am b/konq-plugins/fsview/Makefile.am
new file mode 100644
index 0000000..a400096
--- /dev/null
+++ b/konq-plugins/fsview/Makefile.am
@@ -0,0 +1,51 @@
+INCLUDES= $(all_includes)
+METASOURCES = AUTO
+
+KDE_ICON = fsview
+
+EXTRA_DIST = main.cpp fsview.cpp fsview.h scan.cpp scan.h scantest.cpp \
+ inode.h inode.cpp \
+ fsview.desktop hi32-app-fsview.png
+
+#xdg_apps_DATA = fsview.desktop
+
+messages: rc.cpp
+ LIST=`find . -name \*.h -o -name \*.cpp`; \
+ if test -n "$$LIST"; then \
+ $(XGETTEXT) $$LIST -o $(podir)/fsview.pot; \
+ fi
+
+# Used both by application and KPart
+
+noinst_LTLIBRARIES = libfsview.la
+libfsview_la_SOURCES = treemap.cpp fsview.cpp scan.cpp inode.cpp
+
+# Application
+
+bin_PROGRAMS = fsview
+
+fsview_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+fsview_SOURCES = main.cpp
+fsview_LDADD = libfsview.la $(LIB_KIO) $(LIB_KDECORE) $(LIB_QT)
+
+check_PROGRAMS = scantest
+
+scantest_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+scantest_SOURCES = scantest.cpp
+scantest_LDADD = libfsview.la $(LIB_KIO) $(LIB_KDECORE) $(LIB_QT)
+
+# The KPart
+
+kde_module_LTLIBRARIES = libfsviewpart.la
+libfsviewpart_la_SOURCES = fsview_part.cpp
+libfsviewpart_la_LDFLAGS = -module $(KDE_PLUGIN) $(all_libraries)
+libfsviewpart_la_LIBADD = libfsview.la $(LIB_KPARTS) $(LIB_KIO) -lkonq
+
+partdesktopdir = $(kde_servicesdir)
+partdesktop_DATA = fsview_part.desktop
+
+rcdir = $(kde_datadir)/fsview
+rc_DATA = fsview_part.rc
+
+appsdir = $(kde_appsdir)/.hidden
+apps_DATA = fsview.desktop