summaryrefslogtreecommitdiffstats
path: root/konq-plugins/kuick/kcmkuick/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'konq-plugins/kuick/kcmkuick/Makefile.am')
-rw-r--r--konq-plugins/kuick/kcmkuick/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/konq-plugins/kuick/kcmkuick/Makefile.am b/konq-plugins/kuick/kcmkuick/Makefile.am
new file mode 100644
index 0000000..6c81498
--- /dev/null
+++ b/konq-plugins/kuick/kcmkuick/Makefile.am
@@ -0,0 +1,17 @@
+INCLUDES= $(all_includes)
+
+kde_module_LTLIBRARIES = kcm_kuick.la
+
+kcm_kuick_la_SOURCES = kcmkuick.cpp kcmkuickdialog.ui
+
+kcm_kuick_la_LDFLAGS = $(all_libraries) -module -avoid-version -no-undefined
+kcm_kuick_la_LIBADD = $(LIB_KDEUI) $(LIB_KIO)
+kcm_kuick_la_METASOURCES = AUTO
+
+noinst_HEADERS = kcmkuick.h kcmkuickdialog.h
+
+apps_DATA = kcmkuick.desktop
+appsdir = $(kde_appsdir)/.hidden
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kcmkuick.pot