summaryrefslogtreecommitdiffstats
path: root/noatun-plugins/ffrs/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'noatun-plugins/ffrs/Makefile.am')
-rw-r--r--noatun-plugins/ffrs/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/noatun-plugins/ffrs/Makefile.am b/noatun-plugins/ffrs/Makefile.am
new file mode 100644
index 0000000..96eae2d
--- /dev/null
+++ b/noatun-plugins/ffrs/Makefile.am
@@ -0,0 +1,17 @@
+INCLUDES= -I$(kde_includes)/arts $(all_includes)
+kde_module_LTLIBRARIES = noatun_ffrs.la
+
+noatun_ffrs_la_SOURCES = ffrs.cpp
+
+noatun_ffrs_la_LDFLAGS = $(all_libraries) -module -avoid-version -no-undefined
+noatun_ffrs_la_LIBADD = $(LIB_KFILE) -lnoatun -lm
+
+noatun_ffrs_la_METASOURCES = AUTO
+
+noinst_HEADERS = ffrs.h
+
+noatun_DATA = ffrs.plugin
+noatundir = $(kde_datadir)/noatun
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp *.h -o $(podir)/ffrs.pot