summaryrefslogtreecommitdiffstats
path: root/noatun-plugins/noatunmadness/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'noatun-plugins/noatunmadness/Makefile.am')
-rw-r--r--noatun-plugins/noatunmadness/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/noatun-plugins/noatunmadness/Makefile.am b/noatun-plugins/noatunmadness/Makefile.am
new file mode 100644
index 0000000..973ae51
--- /dev/null
+++ b/noatun-plugins/noatunmadness/Makefile.am
@@ -0,0 +1,10 @@
+INCLUDES= $(all_includes)
+
+kde_module_LTLIBRARIES = noatunmadness.la
+noatunmadness_la_SOURCES = madness.cpp
+noatunmadness_la_LDFLAGS = $(all_libraries) -module -avoid-version -no-undefined
+noatunmadness_la_LIBADD = $(LIB_KFILE) -lnoatun -lm
+noatunmadness_la_METASOURCES = AUTO
+
+noatun_DATA = madness.plugin
+noatundir = $(kde_datadir)/noatun