summaryrefslogtreecommitdiffstats
path: root/noatun-plugins/pitchablespeed/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'noatun-plugins/pitchablespeed/Makefile.am')
-rw-r--r--noatun-plugins/pitchablespeed/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/noatun-plugins/pitchablespeed/Makefile.am b/noatun-plugins/pitchablespeed/Makefile.am
new file mode 100644
index 0000000..b994d98
--- /dev/null
+++ b/noatun-plugins/pitchablespeed/Makefile.am
@@ -0,0 +1,15 @@
+INCLUDES= -I$(kde_includes)/arts $(all_includes)
+
+kde_module_LTLIBRARIES = noatunpitchablespeed.la
+noatunpitchablespeed_la_LDFLAGS = $(all_libraries) -module -avoid-version -no-undefined
+noatunpitchablespeed_la_LIBADD = $(LIB_KFILE) -lnoatun -lm -lartsmodules
+
+noatunpitchablespeed_la_SOURCES = pitchablespeed.cpp speedtuner.ui
+noatunpitchablespeed_la_METASOURCES = AUTO
+noinst_HEADERS = pitchablespeed.h
+
+noatun_DATA = pitchablespeed.plugin
+noatundir = $(kde_datadir)/noatun
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp *.h -o $(podir)/pitchablespeed.pot